uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Page Cannot Be Displayed - MSIE?

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Nov-18-17 03:27 AM EST
Original Message
Page Cannot Be Displayed - MSIE?
Author James on 10-24-2000 at 10:37 (EST)
Hi,
Here is a bug that appears on various hosts, carts and other scripts. When excuting occasionally thru ssl (Thawte), only in msie you get the error message "Page Cannot Be Displayed", hit the back button and resubmit and it works fine. The problem is not the scripts, yet no one seems to have an answer. The sites are hosted on unix boxes, different providers.

It only happens on msie, not netscape. Even crops up with a formmail.cgi. can't get much more bulletproof than that.

Any ideas would be helpful. Clients always assume it is the scripts/carts.

Please email if you have any ideas or solutions, this is quite annoying.

Thanks in advance,
James

E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Page Cannot Be Displayed - MSIE? Bill Weiner, 2000-10-24 14:57:35 (1)
            RE: Page Cannot Be Displayed - MSIE? James, 2000-10-24 17:18:34 (2)
                 RE: Page Cannot Be Displayed - MSIE Fixed! James, 2000-11-09 22:20:01 (3)

Messages In This Discussion
         1. RE: Page Cannot Be Displayed - MSIE?
        Author Bill Weiner on 10-24-2000 at 14:57 (EST)
Hmmm... that's interesting. That sounds like a difficult one to duplicate/resolve. I'm impressed that you narrowed it down to IE and Thawte SSL. I'll keep my eyes open for information/solutions... as most people would probably just assume it was the server... or worse yet, our software :^o
TABLE OF CONTENTS
                 2. RE: Page Cannot Be Displayed - MSIE?
                Author James on 10-24-2000 at 17:18 (EST)
Hi Bill,
I have been using other scripts and some thru various version produces the same anomally. The host providers are aware of it and have no idea what is causing the problem. Could not find anything at microsoft or thawte.

There are no delays during submission, it instantly posts the page cannot be displayed error. Note that it is not an error 404, just cannot be displayed. Merchants get quite a few complaints regularly. Many customers just give up and move on which is not to favorable for merchants.

I really like the upgrade, the class discount 2 really saved the day, I have a few more that will purchase soon.

Adding in the sub send_email:
print MAIL "Subject: " . $messagesubject . $order_number . "nn";
Is also a nice addition. Merchants like to have invoice number in subject field.

Thanks again,
James

TABLE OF CONTENTS
                         3. RE: Page Cannot Be Displayed - MSIE Fixed!
                        Author James on 11-09-2000 at 22:20 (EST)
Found the problem, two hosting companies had same bug and resolved. It is in the httpd.conf. Adding this line resolved this bug making many folks very happy..


BrowserMatch "MSIE" ssl-unclean-shutdown nokeepalive downgrade-1.0
force-response-1.0


Located Resources:
** http://www.egroups.com/message/agoracgi/2883
http://www.egroups.com/message/agoracgi/2887

http://www.egroups.com/message/agoracgi/3019
http://www.egroups.com/message/agoracgi/3022
http://www.egroups.com/message/agoracgi/2798

Hope this helps if anyone runs into this,
James

TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.