uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Ghosting effect with applets

Knowledge Base Lobby : uShop Support Conference : Applets are not being displayed
Nov-19-17 07:32 AM EST
Original Message
Ghosting effect with applets
Author Mike Van Houten on 01-19-2001 at 19:45 (EST)
Some customer shopping two different sites report that there is a ghosting effect with some of the applets especially in Netscape in which the only fix is for the user to move their scroll bar up and down really fast and that seems to unghost it. Do you guys know what I am talking about? And is the problem fixewd in 3.0? Using 2.0 Please reply ASAP as I am concerned my clients are losing sales. :)
Thanks Mike
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  Additional info Mike van Houten, 2001-01-19 19:57:53 (1)
            RE: Additional info Bill Weiner, 2001-01-22 06:58:34 (2)
                 ghosing in 3.0 with fixed tables Collison Corner, 2001-02-03 11:43:29 (3)
                      RE: ghosing in 3.0 with fixed tables Bill Weiner, 2001-02-05 06:23:14 (4)
                           URL to ghosting Collison, 2001-02-24 11:05:32 (5)
                                RE: URL to ghosting Bill Weiner, 2001-02-25 08:28:44 (6)
                                     i have the same problem!! Paul, 2001-11-18 13:52:45 (7)
                                          RE: i have the same problem!! Joseph Pishgar, 2001-11-19 15:54:23 (8)
                                               same problem Paul, 2001-11-19 17:16:28 (9)

Messages In This Discussion
         1. Additional info
        Author Mike van Houten on 01-19-2001 at 19:57 (EST)
When I say ghosting I mean that the applet seems to have been placed on top of itself. Unfortunately I have not been able to reproduce the problem on my computer nor has my fellow webmasters. Several customers have complained about it. I remember seeing a post on here a long time ago regarding this strange ghosting effect. They describe it like the text for the applet and everything such as the pull down button are meshed in with the text. The main site is
www.lodgepolefurniture.com
TABLE OF CONTENTS
                 2. RE: Additional info
                Author Bill Weiner on 01-22-2001 at 06:58 (EST)
We use to get some reports of the "ghosting" effect that you are describing... but it usually had to do with Internet Explorer and not Netscape. That problem did not occur on all IE browsers ... so it kind of lead us to believe it was related to the user's video card/memory.... and it seemed be related to whether the applets are located in an HTML < TABLE > or not.... so it could usually be reduced by specifying a physical WIDTH for the cell (< TD > < /TD >) of the < TABLE > that the applet was located in.

Since the release of uShop 3.0 back in July 2000, we really haven't heard of any such "ghosting" problems. We really didn't make any major changes in the way the Java AWT components are displayed between 2.x and 3.x... .therefore, I'm guessing that the IE browsers just got better at handling applets in tables.

In any case, looking at your "adplatform.htm" page, for instance, it may not hurt to try to specify a WIDTH for the table cell that your applets are in. That is, since the WIDTH of your applets on that page is currently 300, you may want to set the WIDTH of that < TABLE > cell to something like 320.
TABLE OF CONTENTS
                         3. ghosing in 3.0 with fixed tables
                        Author Collison Corner on 02-03-2001 at 11:43 (EST)
I have a client using uShop3.0 and I placed his ~200 applets in fixed tables and the ghosting effect still occurs regularly. This really bugs them. I have tested in both NN and IE5+ with same effects. I found that jiggling the scroll bar helps, but its not a proper fix.
TABLE OF CONTENTS
                                 4. RE: ghosing in 3.0 with fixed tables
                                Author Bill Weiner on 02-05-2001 at 06:23 (EST)
Give me the URL and I will take a look at it.
TABLE OF CONTENTS
                                         5. URL to ghosting
                                        Author Collison on 02-24-2001 at 11:05 (EST)
http://www.nightstandtreasures.net/store/store.html
TABLE OF CONTENTS
                                                 6. RE: URL to ghosting
                                                Author Bill Weiner on 02-25-2001 at 08:28 (EST)
Have you tried it out on a different computer? I just checked out your site with both Netscape and Internet Explorer and all of the applets appeared fine....even after reloading, switching rapidly between the different pages, and running both browsers at the same time.

I did go ahead and looked at your source code anyway (product04.htm), and noticed that you set the TABLE size of 500 on each page... but then the horizontal cell widths to 106 and 490... which is greater than your overall table size of 500. So just in case that is causing any problems with the display of the applets, you should increase that 500 WIDTH accordingly.

Furthermore, since your applet WIDTHS are set to 490, you should really make the WIDTHS of the TABLE cells with the applets in them a litter greater than 490... such as 495... to account for any cell padding.
TABLE OF CONTENTS
                                                         7. i have the same problem!!
                                                        Author Paul on 11-18-2001 at 13:52 (EST)
i have the same problem with "ghosting". i have set up my applets the way you have said but nothing seems to work. my applets are also in tables (how else would you use them if you have a list of items) and when you scroll down the page they become all "choppy" and cut up. please HELP!
i have version 3.x

here is one of the may pages on my site that are having this problem.

http://www.floridapathfinders.com/uShop/STORE/STOREfloridaeagerbeaverchips.html
TABLE OF CONTENTS
                                                                 8. RE: i have the same problem!!
                                                                Author Joseph Pishgar on 11-19-2001 at 15:54 (EST)
Posted at http://www.uburst.com/dcforum/ushop_applets_shopcart/94.html

Hello Paul,
I tested your URL in both IE 5.5 and Netscape 6.1 and it loads perfectly. The applets function well, and when scrolling (even erratically) they keep their style and shape. What browser and version are you using?

Additionally, kudos on a beautifully designed website!

Regards,
Joseph Pishgar
Microburst Technologies, Inc.
www.uburst.com

TABLE OF CONTENTS
                                                                         9. same problem
                                                                        Author Paul on 11-19-2001 at 17:16 (EST)
thanks for the kudos. i really appreciate that. and as for the browser i am using IE 6.0 and i have used 5.0 and netscape 6.2. does it have to do with my mouse. i have a mouse with a wheel on it. i just don't know. maybe my video card? i have no idea. but i tried on a new gateway computer and also on mine. well let me know. and thanks anyways.... hopefully everyone views my site like you do.

sincerely,
paul
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.