uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Still Can't See Amplets when using MAC w/IE4

Knowledge Base Lobby : uShop Support Conference : Applets are not being displayed
Nov-19-17 03:53 AM EST
Original Message
Still Can't See Amplets when using MAC w/IE4
Author mike on 12-27-2000 at 17:20 (EST)
please check my site..http://www.lindenhillartbooks.com
try to add items and check out....the amplets does not show...this only happens in with the macs. Unfortunately the class files are in the root url folder...would this pose a problem ever if i set the codebase to the root folder...eg. https:\www.lindenhillartbooks.com ?

Mike

E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Still Can't See Amplets when using MAC w/IE4 Bill Weiner, 2000-12-28 06:23:52 (1)
  MAC OS Browsers Mike, 2000-12-28 09:54:10 (2)
            RE: MAC OS Browsers Bill Weiner, 2000-12-28 10:42:26 (3)

Messages In This Discussion
         1. RE: Still Can't See Amplets when using MAC w/IE4
        Author Bill Weiner on 12-28-2000 at 06:23 (EST)
I took a look at your uShop 2.x site, and the only thing I saw that may cause a problem (on any browser) is on your "place-order.htm" page. That is, on the applet on that page:

1) You should add the CODEBASE setting to that applet.... so that it matches the CODEBASE of all of your other applet:

codebase= "https://www.lindenhillartbooks.com/"

2) Also, the scriptpath parameter of that applet should be changed from:

"https:www.lindenhillartbooks.com/cgi-bin/ushop_cgiscript.pl"

to:

"https://www.lindenhillartbooks.com/cgi-bin/ushop_cgiscript.pl".

(Use two forward slashes instead of one back slash.... just like regular URLs).

As for overall performance of the applets on IE running on a Macintosh, see the following URL for the latest information:

http://www.uburst.com/uShop/macs.html

(Although the testing performed there was done with uShop 3.x... I believe it also applies to uShop 2.x)

TABLE OF CONTENTS
         2. MAC OS Browsers
        Author Mike on 12-28-2000 at 09:54 (EST)
Thank you for replying. I inserted the codebase settings in the place-order.htm. Thanks again for that hint. I still can't get the mac browser IE4.5 to see the amplets. I read the stats but unfortunately our customer(lindenhillartbooks) is using a mac w/AOL 4.0. what can i advice then about this mac problem?....any other suggestions?
TABLE OF CONTENTS
                 3. RE: MAC OS Browsers
                Author Bill Weiner on 12-28-2000 at 10:42 (EST)
Unfortunately, until the Mac version of IE is fixed to properly handle "static" classes and "static" variables across pages... there is not much that can be done for Mac IE users. I would just recommend putting a note somewhere on your website saying that "Macintosh users must use Netscape." It's not the best solution, but that's it for now.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.