uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
order not processing on I.E.

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Oct-20-17 01:43 PM EST
Original Message
order not processing on I.E.
Author Bradley Nehring on 10-19-2000 at 09:22 (EST)
Greetings!
I am having a problem on I.E. for PC and Mac that I don't think existed before updating to 3.15...

When I get to the point where I press the UshopOrderButton I a) see the Please wait... with PC and then the screen goes blank or b) A new window opens with Please wait... (mac IE 4.5) and freezes.

Please help, kind sirs (and ladies?!)

No problems with Netscape...
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: order not processing on I.E. Bill Weiner, 2000-10-19 13:08:06 (1)
            RE: order not processing on I.E. Bill Weiner, 2000-10-19 13:12:20 (2)
                 Freezes on Please wait... Bradley Nehring, 2000-10-20 07:20:01 (3)
                      RE: Freezes on Please wait... Bill Weiner, 2000-10-20 08:32:00 (4)
                           Thank you! Bradley Nehring, 2000-10-20 08:46:36 (5)
                                Still freezing... Bradley Nehring, 2000-10-20 13:11:49 (6)
                                     RE: Still freezing... Bill Weiner, 2000-10-23 06:03:19 (7)

Messages In This Discussion
         1. RE: order not processing on I.E.
        Author Bill Weiner on 10-19-2000 at 13:08 (EST)
For the latest information regarding the performance on Macs, see this reference page:

http://www.uburst.com/uShop/macs.html

(Although the note about communicating across frames may actually apply to communicating across pages too... we're still looking at that).
TABLE OF CONTENTS
                 2. RE: order not processing on I.E.
                Author Bill Weiner on 10-19-2000 at 13:12 (EST)
But actually, I noticed that you mentioned that the problem is existing on a PC too? No, you should not be having any problems with IE on a PC. A common problem to look out there... is that IE requires that your codebase ends with forward slash.

That is, this codebase will NOT work on IE:

codebase="../classes"

But this codebase WILL work on IE:

codebase="../classes/"

So make sure you have that last forward slash.

If that doesn't solve the problem, give me the URL and I will take a look at it.
TABLE OF CONTENTS
                         3. Freezes on Please wait...
                        Author Bradley Nehring on 10-20-2000 at 07:20 (EST)
Dear Sir,

thank you for your help. Yet I still have a problem with IE for PC freezing on the display_cart.html with the Please wait... message displayed. Why?

Also, although Mac IE 4.5 used to work on 2.0, it doesn't seem to with 3.0

For both 4.5 and 5.0 I don't have a problem of putting things in the shopping cart (since I have changed the "pop-up" to yes), the problem is the items remaining in the cart when I go to the next step.

The second is a lesser problem now...please, if you can, help me with the first! Merci!
http://4starBrazil.com/tours/RDO.html and click on any tour date to proceed.
TABLE OF CONTENTS
                                 4. RE: Freezes on Please wait...
                                Author Bill Weiner on 10-20-2000 at 08:32 (EST)
Looking at your page at:

http://UniversalUnderstanding.com/priceatour/step3/RIM000910.html

The first problem I see is that you are using different codebase for the three applets on that page:

codebase="../classes/"
codebase="../classes"
CODEBASE="../../Templates/..classes"

All codebase settings must be EXACTLY the same, so change all of them to:

codebase="../classes/"

Secondly, once I pressed CONTINUE and was transferred to the page at:

http://UniversalUnderstanding.com/priceatour/step4/SIM000910.html

I see that this page also has the same problem.

ALL CODEBASE SETTINGS SHOULD BE SET TO:

codebase="../classes/"

THIS IS ESPECIALLY TRUE for the uShopOrderButton Applet on that page for which you currently have the codebase set to:

codebase="../classes"

In fact, that is the exact line causing the "Please Wait" problem.

For IE browsers to properly read files, you must have that last forward slash ( / ).... so again, change ALL of the codebase settings on that page (and your others) to be:

codebase="../classes/"

And that will resolve the problem.
TABLE OF CONTENTS
                                         5. Thank you!
                                        Author Bradley Nehring on 10-20-2000 at 08:46 (EST)
I've stared at it a thousand times and didn't see it!

So obvious!

I had just corrected the templates.

Vielen Dank! Merci! Obrigado! Grazie!
TABLE OF CONTENTS
                                                 6. Still freezing...
                                                Author Bradley Nehring on 10-20-2000 at 13:11 (EST)
Dear Sir,

I have corrected the situation as you have noted, but am still having the same problem with the display_cart.html Please wait...

By the way, the problem was with the way Dreamweaver 3.0 interprets what I enter into the Template. Although I would and did enter
../classes/, it would run the update, but "correct" it and remove the last /!

I had to mark all of these applets as editible and then change them by hand.

I hope I've gotten to you before your weekend, and you can help me solve this today!

Once again, many thanks!
Bradley

You can go here...
http://UniversalUnderstanding.com/tours/RDO.html
TABLE OF CONTENTS
                                                         7. RE: Still freezing...
                                                        Author Bill Weiner on 10-23-2000 at 06:03 (EST)
If the review cart page is still freezing after correcting the codebase on your page... then I would suggest checking the codebase of the uShopJSI applet on your "display_cart.html" page...but from looking at your site, I see that you do have that set to:

codebase="../classes/"

So I just went to try out your site with IE in order to try it out.... and it now appears to be working fine.... so I'm guessing you figured out the problem. If not, let me know and I will take another look at it.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.