uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
orders w/smtp

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Dec-14-17 03:48 PM EST
Original Message
orders w/smtp
Author chad maisel on 04-23-2000 at 00:02 (EST)
My cart is working perfectly using the smtp jave. I can't seem to get the cgi to work. Anyway when using the smtp I can place the 1st order, but when I try it a second time it seems to lock up my smtp server and I have to shut the smtp service down and restart it. This is the only time I have had a problem with my smtp server. I'm using Slmail. It happens everytime, the 1st order goes the second locks smtp up, I shut the service down restart it and boom I can send one more order. It happens when I actually place the second order. If I only do one then no problem. Any thoughts.
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  smtp Charlie Edmunds, 2000-04-23 19:18:45 (1)
            cgi chad maisel, 2000-04-26 21:38:20 (2)
                 cgi script Charlie Edmunds, 2000-04-27 18:24:20 (3)
                      RE: cgi Bill Weiner, 2000-04-27 20:18:26 (4)

Messages In This Discussion
         1. smtp
        Author Charlie Edmunds on 04-23-2000 at 19:18 (EST)
Chad,

The smtp applets are kind of a "yes or no" deal. They either work or they don't. You probably should use the cgi script. Do you have perl installed on your server? The cgi script should work with just about any server.

http://www.uburst.com/uShop/reference/ushop_wizard_nt.html is the script configurator for NT.

http://www.uburst.com/uShop/reference/ushop_wizard_nt.html has some good information for troubleshooting cgi script execution issues.

Hope this helps, Charlie Edmunds

TABLE OF CONTENTS
                 2. cgi
                Author chad maisel on 04-26-2000 at 21:38 (EST)
Unfortunately I haven't been able to get the cgi script to work.
TABLE OF CONTENTS
                         3. cgi script
                        Author Charlie Edmunds on 04-27-2000 at 18:24 (EST)
Chad,

Are you able to get any cgi script to run, or is it just uShop that you are having trouble with?

Charlie Edmunds
Microburst Technologies, Inc.
TABLE OF CONTENTS
                                 4. RE: cgi
                                Author Bill Weiner on 04-27-2000 at 20:18 (EST)
If you've never installed/executed any Perl scripts on your server before, then I would suggest trying the test script described at the following URL:

http://www.uburst.com/uStorekeeper/testscript.html

This is the most basic of Perl scripts in that all it does is generate a "Test Page" similar to when your run the script on our site:

http://www.uburst.com/cgi-bin/cgitest.pl

By installing this very basic Perl script, you will see if there is anything special that needs to be done in order to get Perl scripts to execute on your server. In addition, it will verify that your server is setup properly to execute Perl scripts.

Once you get that test script working, installing the ushop_cgiscript will be much easier.

(NOTE: The test script described above is actually on the reference pages for one of our other ecommerce solutions - but the concept is the same).
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.