uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
After display_cart.html appears ushop.pl login screen

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Oct-20-17 08:21 AM EST
Original Message
After display_cart.html appears ushop.pl login screen
Author schwab ralf on 05-06-2002 at 04:00 (EST)
Hello,

since 3 Days i have an error on my shopping-site.
Every thing works fine (put items in cart, start
order process - ushop_order_button - and display
the cart again.
BUT THEN, normally the customer recieves the
fill in adress screen, the ushop.pl login screen
appears !!!
Not everytime, sometimes i can see the next step
- fill in adress - and latest then, the ushop.pl
login screen appears...
What can this be ??
I have changed nothing in the Ushop-Directories.
Is it possible that the webmaster have changed
anything ?

thanks in advance

schwab ralf
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: After display_cart.html appears ushop.pl login screen Bill Weiner, 2002-05-07 06:41:09 (1)
            A Suggestion for uBurst Brian Levine, 2002-05-07 09:17:18 (2)
                 re schwab ralf, 2002-05-07 10:19:02 (3)
                      correct web adress schwab ralf, 2002-05-07 13:11:21 (4)
                           login panel during order process Microburst Support, 2002-05-09 05:58:18 (5)
                                I get that error sometimes, too Nancy, 2002-07-30 14:19:52 (6)
                                     mod_perl / suexec Microburst Support Team, 2002-07-31 05:52:09 (7)

Messages In This Discussion
         1. RE: After display_cart.html appears ushop.pl login screen
        Author Bill Weiner on 05-07-2002 at 06:41 (EST)
It sounds like something may have changed on the server. If you give me the URL, I'll take a look and see if I recognize the problem.
TABLE OF CONTENTS
                 2. A Suggestion for uBurst
                Author Brian Levine on 05-07-2002 at 09:17 (EST)
As the good folks at uBurst explained to me, this happens when control returns to the ushop.pl script with an unknown command.

Bill, it might be a good idea to provide a debug version of ushop.pl that displays $command at the top of the login page.
TABLE OF CONTENTS
                         3. re
                        Author schwab ralf on 05-07-2002 at 10:19 (EST)
Hello,

as i see, they have changed the server apache
version from 1.2.5 SUSE to 1.3.3.
The site is located at:
http://www.friseurversand.de
Is it possible that there is a problem with
the sendmail - because i have on this site
the so called APACHE GUARDIAN installed, which
informs me via email when a error occours (not existing
html page call or server error).
Since the same point of time i recieve also no
error emails (regular i recieve about 50 email
a day).
Another point is, that i cannot access the ushop.pl
If i enter the correct password, ushop.pl asks
me again and again for the password....
Thanks in advance for help

with best regards

schwab ralf
TABLE OF CONTENTS
                                 4. correct web adress
                                Author schwab ralf on 05-07-2002 at 13:11 (EST)
hi there again,

i have made a redirection from our "broken" site
to a site on another server where every thing
works fine.
So, if you want to go to the site with the
ushop.pl error use the following link:
http://www.friseurversand.de/html/
If you go straight to www.friseurversand.de
you will be forwarded to www.friseurversand.com !

Best regards

schwab ralf

TABLE OF CONTENTS
                                         5. login panel during order process
                                        Author Microburst Support on 05-09-2002 at 05:58 (EST)
Your ISP has sent us some very detailed info regarding your server configuration and specific error details that we are using to troubleshoot this.

We will post the resolution here when we figure this out.
TABLE OF CONTENTS
                                                 6. I get that error sometimes, too
                                                Author Nancy on 07-30-2002 at 14:19 (EST)
This is not reproducible. I have seen this error and just grit my teeth that customers do not get it.
TABLE OF CONTENTS
                                                         7. mod_perl / suexec
                                                        Author Microburst Support Team on 07-31-2002 at 05:52 (EST)
With the help of one ISP we were able to eliminate this problem entirely by having him rename the uShop .pl scripts to .cgi

**NOTE: This required renaming the 3 ushop Perl scripts to be .cgi files, and then editing the ushop.pl (renamed to ushop.cgi) near the top, where it links in the other two perl libraries, to specify those files with .cgi extensions too. He had to change his answers to Questions #4, #11 & #12 to reflect the file name changes. One additional change was on the .html page where he invoked the uShopOrderButton applet - this applet specifies a parameter of the uShop perl script which required the new extension name.

The reason that this fixed the problem, as we were told, is that, by default, all cgi programs run by suexec (from your ftp account username). But .pl files run under the apache username (if mod_perl support is ON for your site).

There are 2 ways to solve that:
1. Rename .pl to .cgi
2. To take off the mod_perl support.


TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.