uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
illegal referrer

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Dec-16-17 11:29 PM EST
Original Message
illegal referrer
Author Patrick on 06-13-2001 at 08:32 (EST)
Still having trouble with this.

The applet is set to https://secure/mysite.com
The the script is also the same, I can make everthing work fine with the refferer page off, but when I turn it one i get, illegal referrer.

I have read the forum and followed the instructions with one answer to someones problem but did not fix mine.

Thanks
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Illegal Referrer Joseph Pishgar, 2001-06-13 09:32:49 (1)
  illegal referrer error Jeff Lighthall, 2001-09-19 08:53:32 (2)
            RE: illegal referrer error Joseph Pishgar, 2001-09-19 12:22:44 (3)
  RE: illegal referrer Bill Weiner, 2001-09-19 22:11:44 (4)

Messages In This Discussion
         1. RE: Illegal Referrer
        Author Joseph Pishgar on 06-13-2001 at 09:32 (EST)
Which applet do you have set to "https://secure/mysite.com"? Could you post the code you used here?

Regards,
Joseph Pishgar
TABLE OF CONTENTS
         2. illegal referrer error
        Author Jeff Lighthall on 09-19-2001 at 08:53 (EST)
I am also having problem with the illegal referrer error. Like Patrick I followed all instructions in the reference pages for security. In my cgi directory on my secure server I have file permissions set to 733 (700 would not work). When referrer is set to off in the control panel everything works fine, but when set to on I get the error message. Does anyone have any ideas?

Thanks,
Jeff
TABLE OF CONTENTS
                 3. RE: illegal referrer error
                Author Joseph Pishgar on 09-19-2001 at 12:22 (EST)
Some storefronts have multiple domains, and certain servers do not recognize crossing domains from unsecure to secure, if the domain changes. If it works with the Referrer off, by all means, leave it off. The only issue this could cause is another storefront being setup by someone else, linking to your script, and placing false orders. (Though why someone would take the time to setup a whole seperate storefront just to place false orders is beyond me.) If its an issue, please submit a support request at http://www.uburst.com/supportform.html and we'll troubleshoot it.

Regards,
Joseph Pishgar
Support Engineer
Microburst Technologies, Inc.
TABLE OF CONTENTS
         4. RE: illegal referrer
        Author Bill Weiner on 09-19-2001 at 22:11 (EST)
Patrick and Jeff:

You must make sure that configuration question #3 at the top of your ushop.pl script (the $store_url) is set to the same domain that your HTML pages are located on.

For example, if your order applet is on the URL/page:

http://www.yourdomain.com/placeorder.html

Then configuration question #3 at the top of your ushop.pl script should be set to:

$store_url = "http://www.yourdomain.com/";
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.