uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Odering form and security problems

Knowledge Base Lobby : uShop Support Conference : Problems with trying to Place Orders
Oct-22-17 02:32 AM EST
Original Message
Odering form and security problems
Author Hawk on 02-21-2001 at 00:38 (EST)
I set up uShop and tested it like it said by putting in the URL-http://www.fantasycostume.com/cgi-bin/ushop_cgiscript.pl

and the message came up like it said it would.

i secured the order form
but when you go to the site and add an item to the cart and go to check out i hit the submit button and it comes up with a message saying PLEASE ADD ITEMS TO CART...so i check the cart and the items are there but its like it dont see the the cart or whats in them.

it i take off the security then i dont get that message....not sure if i want to submit my info without the security so im not sure if it will evan go through.....can someone help me figer this out,....cant seem to sleep till i figer this out.....thank you
Hawk
here's the web site im designing
www.fantasycostume.com

E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Odering form and security problems Bill Weiner, 2001-02-21 06:18:54 (1)
            ordering problems Hawk, 2001-07-15 19:06:41 (2)
                 RE: ordering problems Bill Weiner, 2001-07-15 22:23:57 (3)

Messages In This Discussion
         1. RE: Odering form and security problems
        Author Bill Weiner on 02-21-2001 at 06:18 (EST)
For the older version of uShop (uShop 2.x), you must use the uShopOrderButtonCGI applet to transfer the customer (and shopping cart data) to the secure server. See Sections 5, 6 and 7 on the following uShop 2.x reference page for information about configuring the uShopOrderButtonCGI applet:

http://www.uburst.com/uShop/reference2/security.html

FYI: uShop 3.x handles this much more easily and cleaner... so you may want to look into upgrading to uShop 3.x.
TABLE OF CONTENTS
                 2. ordering problems
                Author Hawk on 07-15-2001 at 19:06 (EST)
well i upgraded to 3.x and it's all good but know i get this mesage after i fill aout the formes and credit info...i hit continue and it comes back like this.....Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@safe-order.net and inform them of the time the error occurred, and anything
you might have done that may have caused the error.


what does this mean and how can i resolve this...?

TABLE OF CONTENTS
                         3. RE: ordering problems
                        Author Bill Weiner on 07-15-2001 at 22:23 (EST)
So you're just getting the server error on the final stage of the order process? Well, if you're getting that far in the order process, that means you have the uShop CGI script setup .... ALMOST totally correctly. A "Server Error" appearing only on the last stage of the order process will usually be caused by one of three things:

1) You didn't specify a "Primary" email address for the storeowner. Log in to your uShop Control Panel and make sure that you configured the "Primary" email address under GENERAL SETTINGS - EMAIL NOTIFICATIONS.

2) (MOST LIKELY THE PROBLEM) You're email configuration is not correct. You can verify this by logging in to your uShop Control Panel... pressing the "DIAGNOSTICS" button... and then selecting the "Email Test" button at the bottom of the diagnostic report. Do you get the server error then? If so, then check your email configuration settings in your "ushop.pl" script.... questions #7 - #10 at the top of that script.

3) Your "data" directory does not have write permissions. If you were able to change the settings from your uShop Control Panel... then this is probably not the problem.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.