uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Dropping ordered items

Knowledge Base Lobby : uShop Support Conference : General Questions
Oct-20-17 11:52 AM EST
Original Message
Dropping ordered items
Author W. C. Golden, Sr. on 03-21-2002 at 22:10 (EST)
We have several orders where the customer orders multiple items and selects one of the free magazines on the review page of the order. When we get the order, it only shows the free magazine and drops all the other items. Additionally, the entire order is lost since it was a zero total. Any ideas why? There seems to be no relationship in the browser used. This is really costing us. Any help would be appreciated.
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Dropping ordered items Bill Weiner, 2002-03-22 06:54:56 (1)
            Dropping items W.C., 2002-03-22 08:03:57 (2)
                 RE: Dropping items Bill Weiner, 2002-03-24 11:27:25 (3)
                      Dropping items W. C., 2002-03-27 06:45:18 (4)
                           RE: Dropping items Bill Weiner, 2002-03-28 06:38:33 (5)

Messages In This Discussion
         1. RE: Dropping ordered items
        Author Bill Weiner on 03-22-2002 at 06:54 (EST)
Are you using uShop 2.x or uShop 3.x?

If you are using uShop 3.x... when you say "selects one of the free magazines on the review order page" ... did you add an additional applet to the "template_cart.html" page? In uShop 3.x, you should not put any input applets on that "template_cart.html" page because the item's data would not get passed to the uShop 3.x CGI script.

Or if you are using uShop 2.x, it sounds like a problem with your codebase setting. Remember that the codebase setting of all of your applets must be the same. If you give me the URL, I'll take a look at it.
TABLE OF CONTENTS
                 2. Dropping items
                Author W.C. on 03-22-2002 at 08:03 (EST)
I'm using 3.0. Only an applet for the free magazine is shown on the 'view order' screen where the 'begin order process' button is located. The magazine goes into the cart but everything else is dropped. This only happens sometimes. We get many orders with items and the magazine without a problem, but we get some where all the items are dropped from the cart and only the magazine remains.
TABLE OF CONTENTS
                         3. RE: Dropping items
                        Author Bill Weiner on 03-24-2002 at 11:27 (EST)
That sounds like a codebase problem... where the codebase of all of your applets... including the uShopJSI applet that is on the display_cart.html page ... do not have the EXACT SAME codebase setting. That is, if those codebase values differ... even by just a backslash like this:

codebase="../classes"

and

codebase="../classes/"

Then some browsers could cause the shopping cart data to be lost.

So make sure that the codebase of ALL of the applets are EXACTLY THE SAME.

If that does not solve the problem, then give me the URL and I will take a look at it.
TABLE OF CONTENTS
                                 4. Dropping items
                                Author W. C. on 03-27-2002 at 06:45 (EST)
I'll check that but I noticed something. The orders that drop the items are sending an email that was the order format for version 2.0 (which we replaced with 3.0). Only some of the orders do this. Any ideas??
TABLE OF CONTENTS
                                         5. RE: Dropping items
                                        Author Bill Weiner on 03-28-2002 at 06:38 (EST)
So you have some orders being placed from uShop 2.x and some orders being placed from uShop 3.x? Perhaps you still have a link on your site going to the uShop 2.x order applet/ushop_cgiscript? I would suggest removing all of the old uShop 2.x classes and scripts from your server.... Then check out your site and you should see the stuff that was linking to the old uShop 2.x stuff no longer working.

If that still doesn't reveal the problem, give me the URL and I will take a look at.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.