uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Secure server

Knowledge Base Lobby : uShop Support Conference : General Questions
Oct-22-17 10:39 PM EST
Original Message
Secure server
Author Gordon Houston on 08-01-2001 at 03:25 (EST)
Can you confirm if a secure server is a prerequisite to running uShop? I am getting an "Illegal Referrer Page" error when I try to continue to the final order review page.
A secure server is not otherwise necessary for me as I am interfacing to WorldPay, who provide the secure server.
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  Re: Secure server Joseph Pishgar, 2001-08-01 12:35:48 (1)
  Re: Secure server Joseph Pishgar, 2001-08-02 11:36:49 (2)
            Secure server Gordon Houston, 2001-08-02 15:57:19 (3)
                 Secure server Gordon Houston, 2001-08-02 16:22:45 (4)
                      Re: Secure server Joseph Pishgar, 2001-08-02 20:49:02 (5)

Messages In This Discussion
         1. Re: Secure server
        Author Joseph Pishgar on 08-01-2001 at 12:35 (EST)
A secure server is *not* required to get uShop up and running. Go ahead and submit a support request at www.uburst.com/supportform.html and I'll take a look at your code and setup.

Regards,
Joseph Pishgar
Support Engineer
Microburst Technologies, Inc.
www.uburst.com
TABLE OF CONTENTS
         2. Re: Secure server
        Author Joseph Pishgar on 08-02-2001 at 11:36 (EST)
An "Illegal Referrer Page" error will usually be related to having an incorrect value/typo in configuration question #5 at the top of the script. That is, make sure that the $script_url setting matches the true URL of your script.

Hope this helps.

-Joseph Pishgar
TABLE OF CONTENTS
                 3. Secure server
                Author Gordon Houston on 08-02-2001 at 15:57 (EST)
Hi Joseph,
I don't understand your response. Question #5 refers to the path to the data directory, not the URL. I am sending the script to you separately for you to have a look.

Thanks.
TABLE OF CONTENTS
                         4. Secure server
                        Author Gordon Houston on 08-02-2001 at 16:22 (EST)
Joseph,
On reflection, you may have hit on the problem. Should the URL in question #3, as I have it, be the URL of the first page in the site which contains uShop code, or simply the URL of the site's home page? I have not sent the script file.

Thanks again,
Gordon
TABLE OF CONTENTS
                                 5. Re: Secure server
                                Author Joseph Pishgar on 08-02-2001 at 20:49 (EST)
Question 3 does not affect the functioning of the cgi script itself...
The problem is either in question 4 or question 5. If you do *not* have a secure server, make sure that the "s" in https is left out. Additionally, reference the user's guide on detailed instructions about the data path and how it is setup.

If the problem persists, please contact me at support@uburst.com with your URLs and if convenient, a copy of your ushop.pl script.

Hope this helps.
Regards,
Joseph Pishgar
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.