uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Tech Support
       Support Policy
       Knowledge Base
       Reference Sites
       Software Piracy
       Legal Notices
       Privacy Policy
       Reseller Info
       Contact Us
       Site Map
Internal Server Error

Knowledge Base Lobby : uShop Support Conference : CGI Script Related Problems
Mar-23-18 08:29 PM EST
Original Message
Internal Server Error
Author Tuck Tellir on 08-06-2001 at 16:48 (EST)
when I try to access the control panel with the following URL comand
- I get this error:
The server encountered an internal error or misconfiguration and was unable to complete your request.

Shouldn't I be getting the password screen?

Everything works fine up to place order button Then I get: "Please take a moment to review the contents of your shopping cart. Press BACK to make changes or press CONTINUE to continue with the order process." the next continue button brings me to - "The page cannot be found"

Table Of Contents
  Re: Internal Server Error Joseph Pishgar, 2001-08-07 12:31:26 (1)
            Re: Internal Server Error Bill Weiner, 2001-08-07 22:33:27 (2)
                 testscript Tuck Tellier, 2001-08-14 09:10:58 (3)
                      Re: testscript Joseph Pishgar, 2001-08-15 12:27:00 (4)
                           Re: testscript Bill Weiner, 2001-08-16 05:18:21 (5)
                                CGI Script problems Tuck Tellier, 2001-08-20 13:22:51 (6)
                                     CGI Scripts Tuck Tellier, 2001-08-20 15:10:17 (7)
                                          Test script Tuck Tellier, 2001-08-20 15:20:02 (8)

Messages In This Discussion
         1. Re: Internal Server Error
        Author Joseph Pishgar on 08-07-2001 at 12:31 (EST) doesn't give any feedback to my browser, personally, and I only get the "Page not found" error instead of the Internal Server Error when I try to go to your script. For diagnostic purposes, try installing the cgitest script on your server which can be found at-

Follow the steps there to a tee and we'll see if we can't troubleshoot this.

Joseph Pishgar
Support Engineer
Microburst Technologies, Inc.
                 2. Re: Internal Server Error
                Author Bill Weiner on 08-07-2001 at 22:33 (EST)
Yes, it definitely sounds like a problem configuring/installing the uShop CGI scripts. As Joseph mentioned, try installing the test CGI script from:

... and verify that you can run CGI scripts on your server.
                         3. testscript
                        Author Tuck Tellier on 08-14-2001 at 09:10 (EST)
Thanks, you guys for the help. Sorry to get back so late. I was called out on an emergency. A clients hdw was hit by lightning. It took all week to repair. Still have things to do there.
Concerning the NorthwayCarCare CGI scripts:

I did exactly (I think) what the testscript.html says to do and still get nothing. The error message says:Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Send me your e-mail address and I will send you copies othe .pl scripts I am using and the general location on the unix server.

Thanks again.

Tuck Tellier
                                 4. Re: testscript
                                Author Joseph Pishgar on 08-15-2001 at 12:27 (EST)
Hello Tuck,

Go ahead and send your information and scripts on over to, or better yet use the support form at and we'll take a look at it.

From what it sounds like thus far, its either a perl path problem or permissions set wrong. Could also be file extensions not supported by your server.

Joseph Pishgar
                                         5. Re: testscript
                                        Author Bill Weiner on 08-16-2001 at 05:18 (EST)
Yes, we'll take a look at the settings of your test script.... which basically consists of the "path to perl" that you are using....

But if that path to perl is correct.... and the test script has the correct file extension for your server *".cgi" or ".pl") ....

Then that is a good indication that your account on your server might not be setup correctly to run Perl scripts. If that is the case, I would suggest contacting your web hosting provider and telling him/her that you have a VERY BASIC test script that is not running on your server. They should then be able to recognize the problem.
                                                 6. CGI Script problems
                                                Author Tuck Tellier on 08-20-2001 at 13:22 (EST)
Ok, Guys,

I got thru the perl path to .pl by changing the UNIX setting in my Homesite 4.5 to strip the carriage returns. Now I get into the log on screen with the password and fill in the first screen but then I get:
Unable to open /www/cgi-bin/data/ushop-settings.txt
What next?


                                                         7. CGI Scripts
                                                        Author Tuck Tellier on 08-20-2001 at 15:10 (EST)

I got past the ushop-settings.txt problem by goint to the trupbleshooting section and changing the address to the date folder to "./data/"
Now I am trying to figure out the rest of the settings for the shoppingcart.

Stay tuned!

                                                                 8. Test script
                                                                Author Tuck Tellier on 08-20-2001 at 15:20 (EST)
Now the script works!



© 2003 Microburst Technologies, Inc.