uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Please help getting crazy

Knowledge Base Lobby : uShop Support Conference : Applets are not being displayed
Dec-16-17 11:29 PM EST
Original Message
Please help getting crazy
Author marcel emmen on 04-17-2001 at 17:48 (EST)
Hi there,

I'm getting crazy.
My site at http://www.emmenmode.com is ready for almost 95% but something very strange is happening with the uShopInput5.class when i test it in Netscape 6.01 (in IE 5.5 it's no problem)

I use a database to generate the pages. Everything is working fine. If i go to the shoppingpart (lets say the men's department) and select a brand the articles show up and the applet shows oke! Also if i do a search form the main page everything is working fine.

But if i select the popup menu (new articles since..) on the main page http://www.emmenmode.com/html/index_en.html
Lets say 4 days old all articles show up but the applet not; Netscape gives a error which says: Bad magic number

The problem only exist if i use the (new articles since) options. But the strange thing is that the script calls the exact same database when i do this from a search or a department!

Microsoft IE gives no problem and shows everything ok.

Please let me know what this error means or better if you can find the problem?

Thanks a lot.

Marcel
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Please help getting crazy Bill Weiner, 2001-04-18 05:46:10 (1)

Messages In This Discussion
         1. RE: Please help getting crazy
        Author Bill Weiner on 04-18-2001 at 05:46 (EST)
"Bad Magic Number" errors are usually caused by not transferring the class files to your server in BINARY transfer mode. However, since the applets work fine on Netscape 4.x, IE 5.x, and even on Netscape 6 when you are browsing the different departments.... I'm not sure why you are getting a "Bad Magic Number" error only when using your "View New Articles" option.

I did notice that for your "View New Articles" option, you first call the script "whatsnewen.cgi"... which seems to redirect to the "db.cgi" script... but I don't see why that would cause a problem.

What you may want to try, however, is setting the codebase of ALL of your applets to be the FULL URL of your classes. That is, usually when pages with the uShop applets are being dynamically generated, you must use the FULL URL of your classes as opposed to a relative URL. Hopefully making that change would not be difficult:

1. change the codebase setting in your database
2. set the special codebase PARAMETER of your uShopOrderButton
3. change the codebase setting of the uShopJSI applet on your display_cart.html page

And see if that resolves the problem.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.