uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
Applet UshopOrderDeluxeCGI can't start:ERROR

Knowledge Base Lobby : uShop Support Conference : Applets are not being displayed
Dec-12-17 03:24 AM EST
Original Message
Applet UshopOrderDeluxeCGI can't start:ERROR
Author webgeek on 05-31-2000 at 19:58 (EST)
the heading says it all. This app was working this afternoon, but I fired it up this evening and this is the error I got.

there are no missing semicolons, and the only parameters that have been changed lately are the shipping parameters.

It seems it will run sometimes and not others.
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: Applet UshopOrderDeluxeCGI can't start:ERROR Bill Weiner, 2000-05-31 20:09:58 (1)
            URL webgeek, 2000-05-31 20:16:00 (2)
                 RE: URL Bill Weiner, 2000-05-31 23:23:22 (3)

Messages In This Discussion
         1. RE: Applet UshopOrderDeluxeCGI can't start:ERROR
        Author Bill Weiner on 05-31-2000 at 20:09 (EST)
Make sure that you are letting the applet load all the way. Otherwise, send me the URL and I will take a look at it.
TABLE OF CONTENTS
                 2. URL
                Author webgeek on 05-31-2000 at 20:16 (EST)
http://www.webgeekdesign.com/sc2/

link to the test site. Poke around and try placing an order.

thanks
TABLE OF CONTENTS
                         3. RE: URL
                        Author Bill Weiner on 05-31-2000 at 23:23 (EST)
I took a look at your site and noticed the following error when going to your order page:

"java.lang.StringIndexOutOfBoundsException: String index out of range: -1"

So I took a look at the parameters of your uShopOrderDeluxeCGI applet and noticed a problem with your "handlingtable" parameter. That particular parameter you cannot set to "NONE". If you don't want a handling table, then don't specify that parameter at all. Therefore to correct the problem, just delete that "handlingtable" parameter entirely from your HTML.

On a side note, while checking out your site, I did notice two other minor problems on your http://www.webgeekdesign.com/sc2/sc_kits.shtml#Scanspeak7 page. That is, on that page, I notice that you get a "# Applet exception: error: java.lang.ClassFormatError: Bad magic number" error. "Bad magic number" errors are a good indication that the class file was transferred to the server in ASCII as opposed to BINARY transfer mode. Since the error does not show up on other pages, it may just be your "uShopInputOptionQuantity1.class" file....so try transferring that file to your server again...and be sure to use BINARY transfer mode.

The other slight problem that I see with your
http://www.webgeekdesign.com/sc2/sc_kits.shtml#Scanspeak7 page, is that the CODEBASE does not match the CODEBASE setting of all of your other pages. That is, the HTTP is all capitalized and there is an extra space after the last forward slash (/).... These slight differences may or may not affect all browsers, but to be safe you may want to change the CODEBASE to match the value that you are using on the other pages EXACTLY.

Anyway, getting back to the order applet error, just remove the "handlingtable" parameter that should correct that problem.

TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.