uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
https-Netscape4.7/Applets-Netscape6

Knowledge Base Lobby : uShop Support Conference : Applets are not adding items to Shopping Cart
Oct-21-17 06:36 AM EST
Original Message
https-Netscape4.7/Applets-Netscape6
Author Cathy Roberts on 07-13-2001 at 10:09 (EST)
Hello, When using Netscape 4.7 everything works fine until you press the Continue Order Process button. Secure page tries to load and can't. In Netscape 6 none of the applets will load at all. Everything works great with IE5.5. Haven't tested anything else. Web site: http://www.thehouseoflinens.com.

Thanks for your help - Cathy
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: https-Netscape4.7/Applets-Netscape6 Bill Weiner, 2001-07-15 22:36:04 (1)
            "RE: https-Netscape4.7/Applets-Netscape6" Cathy Roberts, 2001-07-16 19:28:59 (2)
            "RE: https-Netscape4.7/Applets-Netscape6" Cathy Roberts, 2001-07-16 20:44:27 (3)
                 RE: https-Netscape4.7/Applets-Netscape6 Bill Weiner, 2001-07-17 06:20:48 (4)
                       "https-Netscape4.7/Applets-Netscape6" Cathy, 2001-07-17 17:50:33 (5)

Messages In This Discussion
         1. RE: https-Netscape4.7/Applets-Netscape6
        Author Bill Weiner on 07-15-2001 at 22:36 (EST)
As you can see by trying out the applets on our site with Netscape 6:

http://www.uburst.com/uShop/reference/applets.html

uShop has successfully been tested on Netscape 6 and should be working for you.

So..... I took a look at your site at:

http://www.thehouseoflinens.com/

And noticed on your front page that you are getting the following error in the Java Console:

------------
ClassFormatError: uShopInitialize (Extra bytes at the end of the class file)
------------

This tells me that your class files may have been corrupted in some way. I would suggest downloading a fresh copy of the uShop .class files and transferring them to your server.. being sure to transfer the class files in BINARY transfer mode.
TABLE OF CONTENTS
                 2. "RE: https-Netscape4.7/Applets-Netscape6"
                Author Cathy Roberts on 07-16-2001 at 19:28 (EST)
HI Bill and thank you. I did what you said and am now getting the following messages in the java console. thanks again for your help.

java.lang.NoClassDefFoundError: uShopInitialize (wrong name: uShopInput19)

at java.lang.ClassLoader.defineClass0(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at sun.applet.AppletClassLoader.findClass(Unknown Source)

at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadClass(Unknown Source)

at java.lang.ClassLoader.loadClass(Unknown Source)

at sun.applet.AppletClassLoader.loadCode(Unknown Source)

at sun.applet.AppletPanel.createApplet(Unknown Source)

at sun.plugin.AppletViewer.createApplet(Unknown Source)

at sun.applet.AppletPanel.runLoader(Unknown Source)

at sun.applet.AppletPanel.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

java.lang.NoClassDefFoundError

at uShopInput19.init(uShopInput19)

at sun.applet.AppletPanel.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)
TABLE OF CONTENTS
                 3. "RE: https-Netscape4.7/Applets-Netscape6"
                Author Cathy Roberts on 07-16-2001 at 20:44 (EST)
I did it again and I'm back to the "extra bytes". As to transferring them in binary mode, neither Web Publishing Wizard nor my Unix servers upload feature give me that option. they are being listed as Java files on my server though and everything is still working in IE5. HELP - thanks.
TABLE OF CONTENTS
                         4. RE: https-Netscape4.7/Applets-Netscape6
                        Author Bill Weiner on 07-17-2001 at 06:20 (EST)
Is it possible for you to use WS-FTP to upload the class files in BINARY mode to your server? You can get a free copy here:

http://www.wsftp.com/

Otherwise, your other utilities may be working...you may just need to:

1) Delete ALL of the class files from your server.

2) Clear your browser's cache and exit your browser.

3) Retransfer ALL of the class files to your server again....again using BINARY mode if possible. (RAW mode would also work if you have that option).


And also, just to make sure that it is not something with your browser, did you try out the applet reference on our site:

http://www.uburst.com/uShop/reference/applets.html

.... just to make sure that your Netscape 6 browser is functioning properly?

TABLE OF CONTENTS
                                 5.  "https-Netscape4.7/Applets-Netscape6"
                                Author Cathy on 07-17-2001 at 17:50 (EST)
Thank you so much - that did the trick. I saw as I was overwriting the files that they were one byte more and in some cases several bytes short. I continue to learn and be amazed thanks to people like you.

Kindest regards,
Cathy
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.