uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
applets not displaying for certain users

Knowledge Base Lobby : uShop Support Conference : Applets are not adding items to Shopping Cart
Oct-22-17 10:39 PM EST
Original Message
applets not displaying for certain users
Author Nancy Bohs on 02-05-2002 at 13:55 (EST)
One customer using Win95, IE 5.00, with Java enabled, reports seeing only a place-holder instead of the uShopInputQuantity3.class applet (the only input applet I use on our site.) I've tested our site in various versions of both IE and Navigator, and under different OS's but never saw this happen.

I used dot notation for specifying the relative path of my class files rather than the absolute path. Is this what is likely to be causing the problem? It looks like this is a good bet based on answers to previous posts on the forum, and your CODEBASE support page, but I kind of thought IE 5 wouldn't be in the "older" browser category. I just want to touch base in case I'm missing something before I go and change the CODEBASE references, in case it's something like a memory issue - I've got a lot of applets on several of our pages. Our site is www.altmoor.com.

Thanks!!
E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: applets not displaying for certain users Bill Weiner, 2002-02-05 21:09:35 (1)
            reply to Re: applets Nancy Bohs, 2002-02-06 09:23:03 (2)
            2nd reply to Re: applets Nancy Bohs, 2002-02-06 09:38:49 (3)
            3rd reply to Re: applets... Nancy Bohs, 2002-02-06 10:51:57 (4)
                 RE: 3rd reply to Re: applets... Bill Weiner, 2002-02-06 19:27:54 (5)
  applets and explorer 6.0 ?? Shawn Erikson, 2002-02-09 14:27:41 (6)
            appets, JVM & JIT Nancy Bohs, 2002-02-10 08:17:49 (7)

Messages In This Discussion
         1. RE: applets not displaying for certain users
        Author Bill Weiner on 02-05-2002 at 21:09 (EST)
No. That doesn't sound like a codebase problem to me.... particularly if it works on other versions IE and Navigator browsers. (And no, I wouldn't call IE 5.0 and "old" browser either).

Providing Java (not just JavaScript) was indeed enabled, my guess the problem was related to either:

1) The customer just didn't give the applet long enough time to load (ie. traffic related).

or

2) The applet is in a table and the table cell does not explicitly have a WIDTH set (this sort of problem sometimes shows up on certain browser versions but not on others).

But if you give me the URL of your store and the URL of the page with the applet on it, I'll take a look at it and see if I notice anything.
TABLE OF CONTENTS
                 2. reply to Re: applets
                Author Nancy Bohs on 02-06-2002 at 09:23 (EST)
Yes, the applets are in a table and the cell width is not explictly set. I set the cell width (in pixels) on one page and will ask the customer to view.

It would be great if you could look at an unchanged page: http://www.altmoor.com/catalog/TTremote.html

(Actually most pages in the catalog have applets in tables with unspecified cell widths except for the one I just changed: ../InnoRemote.html. So look at whatever you feel like, they all have the same design.)

Thanks!!
TABLE OF CONTENTS
                 3. 2nd reply to Re: applets
                Author Nancy Bohs on 02-06-2002 at 09:38 (EST)
One other thing I forgot to mention: customer is using a T1 connection from her office, so I figured traffic and speed weren't an issue.
TABLE OF CONTENTS
                 4. 3rd reply to Re: applets...
                Author Nancy Bohs on 02-06-2002 at 10:51 (EST)
Setting an explicit cell width did not make the applets visible to the customer running Win95 and IE 5.00, however she can view the flash button contained in another cell on that page: http://www.altmoor.com/catalog/InnoRemote.html

She had a co-worker look at the site using Win98, unknown version of IE, and it displayed fine. Sounds like the issue is pretty narrow in scope and possibly related to this customer's specific machine/software.


TABLE OF CONTENTS
                         5. RE: 3rd reply to Re: applets...
                        Author Bill Weiner on 02-06-2002 at 19:27 (EST)
RELATING TO USHOP 2.X

I took a look at your uShop 2.X website page at:

http://www.altmoor.com/catalog/TTremote.html

...with a couple different browsers from my Win98 machine:

- Netscape 4.73
- IE 5.5
- Netscape 6.0
- Netscape 6.2

...and the applets seemed to work fine for me too. (Unfortunately, I don't have IE 5.0 on the computer I'm currently using so I wasn't able to try that out.)

I did go ahead and took a look at your HTML, and that all seemed to be fine... except for possibly explicitly setting a WIDTH for any table cells that have applets in them, such as:

< TD WIDTH=160 >

But I'm not sure if that would be causing such a problem on only that version of the browser and not others.

It could just be something with that specific machine/software... as you mentioned.




TABLE OF CONTENTS
         6. applets and explorer 6.0 ??
        Author Shawn Erikson on 02-09-2002 at 14:27 (EST)

Since the begging of this year I too seem to have an increasing number of complaints from customers who phone in and are unable to see my applets as well. We used to receive about 1-2 of these a month now itís about 20% of our sales, which have dropped dramatically over the past few weeks. Also due to seasonal trends.


In January we upgraded to 3.45 with the new classes and display files.

I do use tables. Main page tables have widths as a percent (i.e. 100%), if this counts as being explicit? While tables where applets should appear are both large enough for the applets and explicit in width.

I have rechecked my code base.

Most complaints are from Explorer 6.0 users, although I can view my pages in 6.0.

Assuming visitors may have browserís settings incorrect I am going to add a help page on my site if they are unable to view applets or add items to their cart, although not currently understanding why they are not appearing isnít a good starting point for me.

In terms of correct Explorer 6.0 Java settings, where and which settings should visitors have selected?

I searched explorerís index for Java or Java Scripts or settings gives no information. Very silly. While under Internet options/advanced there are 3 Java VM settings but I am uncertain which if any are needed.

Here is a small page from my site on which customers are unable to view applets.

http://www.thegamestore.com/games/games.html

Thank you for your time.
Shawn Erikson
TABLE OF CONTENTS
                 7. appets, JVM & JIT
                Author Nancy Bohs on 02-10-2002 at 08:17 (EST)
This actually seems to be a problem with certain versions and configurations of IE with the JIT compiler enabled. IE 6 is mentioned frequently in microsoft's knowledge base articles. See article Q155163 for IE for Win95, article Q168806 for the others. Basically it looks like the users need to disable IE JIT in Win95 versions, and download a new JVM and/or disable JIT in the later versions.
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.