uShop English (U.S.) for 179!

uStorekeeper English (U.S.) for 149!

 Products
       uTest
       uReserve
       uShop
       uStorekeeper
       uGolf
       uDirectory
       uSignIn
 Tech Support
       Support Policy
       Knowledge Base
            uTest
            uReserve
            uShop
            uStorekeeper
            uGolf
            uDirectory
            uSignIn
       Documentation
       Reference Sites
 Legal
       Software Piracy
       Legal Notices
       Privacy Policy
       Licensing
 Miscellaneous
       Reseller Info
       Contact Us
       Site Map
resource name

Knowledge Base Lobby : uReserve Support Conference : General Questions
Oct-18-17 09:07 AM EST
Original Message
resource name
Author Ed on 04-24-2002 at 19:55 (EST)
LAST EDITED ON Apr-25-02 AT 00:00 AM (EST)


Hello, I tried to add a name with & in the middle and it would show "Unknown Reource Unable to locate information for this resource" when you tried to schedule. For example A&W. Is there a way for me to make this possible. Thanks

E-MAIL AUTHOR | TABLE OF CONTENTS

Table Of Contents
  RE: resource name Bill Weiner, 2002-04-29 05:30:49 (1)

Messages In This Discussion
         1. RE: resource name
        Author Bill Weiner on 04-29-2002 at 05:30 (EST)
Because the ampersand (&) is a special character when used in the URL, you really can't use an "&" in a Resource Name.

As a work-around... which I haven't tried myself... this may work:

STEP 1: Make a backup of your current ureserve.pl script.

STEP 2: Open your ureserve.pl script with any text editor such as WordPad.

STEP 3: Do a search on the following line:

$temp_string =~ s/ /_/g;

(There will be exactly TWO occurrances of this line in the script.)

STEP 4: Immediated AFTER BOTH of the occurrances, add the following line:

$temp_string =~ s/&/%26/g;

(So you will be adding the above line in TWO places in the script).

STEP 5: Save the script... as TEXT if your editor asks... and try it out.

Good luck!
TABLE OF CONTENTS

© 2003 Microburst Technologies, Inc.