www.uburst.com www.uburst.com

"AuthorizeNet problem"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Configuration Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"AuthorizeNet problem"
Posted by George Cunningham on Dec-13-00 at 06:00 AM (EST)
Hello, I set up my store and everything works perfectly except AuthorizeNet. When I transport to AuthorizeNet from my site, it takes the transaction and when I press the 'submit this transaction' button it returns 'Illegal Referrer Page'. AuthorizeNet has processed it and sends confirmation but it never takes me to the confirmation page on the store. So what am I doing wrong with this?
Thanks
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: AuthorizeNet problem, Bill Weiner, Dec-13-00, (1)
URL, George Cunningtham, Dec-13-00, (2)
RE: URL, Bill Weiner, Dec-13-00, (3)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: AuthorizeNet problem"
Posted by Bill Weiner on Dec-13-00 at 03:06 PM (EST)
Try logging in to your merchant account at Authorize.Net and then under "Settings" select "Manage URLs". Make sure that the URL of your ustorekeeper.pl file is properly listed there as a "Valid Browser Referral URL" and a "Valid ADC or Receipt Link URL".
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "URL"
Posted by George Cunningtham on Dec-13-00 at 06:19 PM (EST)
Hey Bill, I did have the URL set at Authorizenet to the directory of the script, in this case to the secure server from which Authorizenet would need the referrer to be. I purposely made that URL wrong to make Authorizenet give me an error and it did but it read,"Invalid Referrer" and in small text to the left on the page. I called Authorizenet and they said they dont have it setup to say 'Illegal Referrer', theres says 'Invalid referrer' and to speak with the cart software manufacturer. So here I am :P.
I then proceeded to put the secure URL and nonsecure URL to the script in Authorizenets referrer page, but I only put the directory not the actual file name 'ustorekeeper.cgi'. So it appears that the script is thinking there is an illegal referrer when it gets a response code from Authorizenet? Thats just a guess,tell me what ya think.
Thanks a ton
George
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: URL"
Posted by Bill Weiner on Dec-13-00 at 08:17 PM (EST)
Oh, so your saying that it is uStorekeeper that's outputting that "Illegal Referrer" error after Authorize.Net has processed the payment information and is trying to transfer back to the uStorekeeper script? Hmmm.... that message really shouldn't be occuring at that time. Give me the URL and I will take a look at it. Or better yet, generate a "Diagnostics Report" and send me the results at support@uburst.com. I'll take a look at it.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.