www.uburst.com www.uburst.com

"UshopInput3 applet works w/IE not Netscape"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

General Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"UshopInput3 applet works w/IE not Netscape"
Posted by W. C. Golden, Sr. on Sep-28-02 at 10:49 AM (EST)
On our site antiquesupply.com we have a link to '2000' pieces of hardware which uses the applet and works with Netscape and one to 1100 books that uses the same applet that does not work. They BOTH work with IE. Any suggestions??
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: UshopInput3 applet works w/IE n..., Bill Weiner, Sep-30-02, (1)
Applet works in IE not in Netscape, W. C., Oct-03-02, (2)
RE: Applet works in IE not in Netsc..., Bill Weiner, Oct-04-02, (3)
-same-, W. C., Oct-04-02, (4)
RE: -same-, Bill Weiner, Oct-08-02, (5)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: UshopInput3 applet works w/IE not Netscape"
Posted by Bill Weiner on Sep-30-02 at 04:32 AM (EST)
Some browsers are less forgiving of HTML syntax error than others, so make sure the HTML of the 1100 books applet (and the HTML around the applet) is correct. Ie. Any HTML tags have the appropriate closing tags, parameters are in the correct format, etc.

If that doesn't resolve the problem, then give me the URL of the page with the problem and I'll take a look at it.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Applet works in IE not in Netscape"
Posted by W. C. on Oct-03-02 at 04:48 PM (EST)
The calling frame that calls the book frame is http://antiquesupply.com/prod-booksearch1.html and the displayed results is a modified display_product.html stored at http://antiquesupply.com/java/display_product.html
which is used as the results frame for hardware (http://antiquesupply.com/prod-hardware1.html)

Note: there are no graphics file for the books as there is for hardware. It does work in IE but not Netscape.

Thanks for any help.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: Applet works in IE not in Netscape"
Posted by Bill Weiner on Oct-04-02 at 05:19 AM (EST)
I see a couple things that could cause the problem:

#1) The codebases of your applets are not exactly the same.

CODEBASE="./java/"
CODEBASE="/java/"
CODEBASE="http://antiquesupply.com/java/"

They might translate to be the same directory, but some browsers will not treat them all as being exactly the same. Refer to:

http://www.uburst.com/uShop/codebase.html

For a complete description of the codebase parameters.

But before messing around with the codebase settings, check out #2 below:

#2) Considering that you are using the search applets and from looking at your "display_product.html" page... it appears you are not using the latest uShop update.

http://www.uburst.com/uShop/updates.html

You should be using at least version 3.45 or later.

As part of this update, you will actually have two display_product pages (display_product.html and display_product2.html)... which I don't see on your site at:

http://antiquesupply.com/java/display_product.html
http://antiquesupply.com/java/display_product2.html

So I would first recommend upgrading to the latest version of uShop (uShop 3.45 or later) and see if that resolves the problem.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "-same-"
Posted by W. C. on Oct-04-02 at 04:26 PM (EST)
Updated to 3.5. Now in Netscape and IE only the hardware works, the book search does not work in either. The codesource is the same "./java/" in both. Could it be because there are not graphics for the books?

Also, what is the 2nd display_product html for?

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . "RE: -same-"
Posted by Bill Weiner on Oct-08-02 at 05:09 AM (EST)
The two "display_product" and "display_cart" pages that are included with uShop 3.5 are designed to handle different browser, JVM, and Java Plug-in differences.

Looking at your display_product pages at:

http://antiquesupply.com/java/display_product.html
http://antiquesupply.com/java/display_product2.html

I see the uShopJSI applet of one page has a codebase setting of:

codebase="../java/"

While the uShopJSI applet of the other page has a codebase setting of:

codebase="../classes/"

See the following URL for the recommended directory structure/codebase setting:

http://www.uburst.com/uShop/codebase.html

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.