www.uburst.com www.uburst.com

"Dropping ordered items"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

General Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Dropping ordered items"
Posted by W. C. Golden, Sr. on Mar-21-02 at 10:10 PM (EST)
We have several orders where the customer orders multiple items and selects one of the free magazines on the review page of the order. When we get the order, it only shows the free magazine and drops all the other items. Additionally, the entire order is lost since it was a zero total. Any ideas why? There seems to be no relationship in the browser used. This is really costing us. Any help would be appreciated.
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Dropping ordered items, Bill Weiner, Mar-22-02, (1)
Dropping items, W.C., Mar-22-02, (2)
RE: Dropping items, Bill Weiner, Mar-24-02, (3)
Dropping items, W. C., Mar-27-02, (4)
RE: Dropping items, Bill Weiner, Mar-28-02, (5)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Dropping ordered items"
Posted by Bill Weiner on Mar-22-02 at 06:54 AM (EST)
Are you using uShop 2.x or uShop 3.x?

If you are using uShop 3.x... when you say "selects one of the free magazines on the review order page" ... did you add an additional applet to the "template_cart.html" page? In uShop 3.x, you should not put any input applets on that "template_cart.html" page because the item's data would not get passed to the uShop 3.x CGI script.

Or if you are using uShop 2.x, it sounds like a problem with your codebase setting. Remember that the codebase setting of all of your applets must be the same. If you give me the URL, I'll take a look at it.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Dropping items"
Posted by W.C. on Mar-22-02 at 08:03 AM (EST)
I'm using 3.0. Only an applet for the free magazine is shown on the 'view order' screen where the 'begin order process' button is located. The magazine goes into the cart but everything else is dropped. This only happens sometimes. We get many orders with items and the magazine without a problem, but we get some where all the items are dropped from the cart and only the magazine remains.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: Dropping items"
Posted by Bill Weiner on Mar-24-02 at 11:27 AM (EST)
That sounds like a codebase problem... where the codebase of all of your applets... including the uShopJSI applet that is on the display_cart.html page ... do not have the EXACT SAME codebase setting. That is, if those codebase values differ... even by just a backslash like this:

codebase="../classes"

and

codebase="../classes/"

Then some browsers could cause the shopping cart data to be lost.

So make sure that the codebase of ALL of the applets are EXACTLY THE SAME.

If that does not solve the problem, then give me the URL and I will take a look at it.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "Dropping items"
Posted by W. C. on Mar-27-02 at 06:45 AM (EST)
I'll check that but I noticed something. The orders that drop the items are sending an email that was the order format for version 2.0 (which we replaced with 3.0). Only some of the orders do this. Any ideas??
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . "RE: Dropping items"
Posted by Bill Weiner on Mar-28-02 at 06:38 AM (EST)
So you have some orders being placed from uShop 2.x and some orders being placed from uShop 3.x? Perhaps you still have a link on your site going to the uShop 2.x order applet/ushop_cgiscript? I would suggest removing all of the old uShop 2.x classes and scripts from your server.... Then check out your site and you should see the stuff that was linking to the old uShop 2.x stuff no longer working.

If that still doesn't reveal the problem, give me the URL and I will take a look at.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.