www.uburst.com www.uburst.com

"qmail" vs. "sendmail"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Problems with trying to place orders.
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"qmail" vs. "sendmail"
Posted by Drew on Nov-01-00 at 04:58 PM (EST)
I've installed the freebie version of uShop on a Linux server, and everything works fine EXCEPT: I get no email notification sent to either me or the customer. I've tried every troubleshooting tip listed, to no avail. My hosting company says that instead of using "sendmail" my server uses "qmail". However, they say that qmail can use a "wrapper" to emulate sendmail, and that should do the trick. But they don't explain exactly how to do it. Any help here?? I really like uShop, and will definitely upgrade to a purchased version...once I get this snag figured out. HELP!!!
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: "qmail" vs. "sen..., Bill Weiner, Nov-01-00, (1)
Me Too, EmporerEJ, Nov-16-00, (2)
RE: Me Too, Bill Weiner, Nov-16-00, (3)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: "qmail" vs. "sendmail""
Posted by Bill Weiner on Nov-01-00 at 07:04 PM (EST)
I believe you can use qmail instead of sendmail by simply specifying the path of qmail on your server instead of sendmail. That is, instead of specifying the $sendmail_path configuration question in the uShop CGI script as something like this:

$sendmail_path = "/usr/lib/sendmail";

Just specify it as something like this:

$sendmail_path = "/usr/lib/qmail";

... where the "/usr/lib/qmail" is whatever the path to qmail on your server is.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Me Too"
Posted by EmporerEJ on Nov-16-00 at 02:58 AM (EST)
How did you fix this?
You are describing my problem, but I'm on a win2k server.
it uses mail.exe, and the cart acts like it's all good, but doesn't send the customer or me the order.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: Me Too"
Posted by Bill Weiner on Nov-16-00 at 07:54 AM (EST)
If you are trying to use "qmail" instead of "sendmail".... then try removing the "-n" as described at this posting:

http://www.uburst.com/dcforum/ushop_cgi/106.html

But "qmail" is more of a UNIX server thing...

If you have a Windows server and the built-in SOCKETS and BLAT email options are not working..... then I would suggest submitting a support request (if you have a license number) or just sending an email to support@uburst.com (if you are using one of the trial versions). We have versions of the uShop scripts that use of various other email techniques for various servers/mail programs.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.