www.uburst.com www.uburst.com

""(Illegal Referrer Page)""

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Problems with trying to place orders.
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
""(Illegal Referrer Page)""
Posted by Luis Ruben Rosario on Sep-22-00 at 04:34 PM (EST)
extra info for you: ushop.pl
I configure the secure with this address
https://orchid.site-secure.net/rameynet/cgi-bin/newtools/ushop.pl
the same that the place order bottom

I try but the error is not solve
website is under construction enter to "Nes Tools" that the only page of products configurated with the java applets.

http://www.rameynet.com/newtools/frame.htm

thanks

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Illegal Referrer Page, Bill Weiner, Sep-25-00, (1)
Thanks Bill Weiner , Luis Rosario, Sep-25-00, (2)
Illegal Referrer Page, Roger, Nov-03-00, (3)
RE: Illegal Referrer Page, Bill Weiner, Nov-04-00, (4)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Illegal Referrer Page"
Posted by Bill Weiner on Sep-25-00 at 10:02 AM (EST)
That "Illegal Referrer Page" error may have to do with the fact that you have your "uShopOrderButton" on the following secure page:

https://orchid.site-secure.net/rameynet/newtools/store/placeorder.htm

That "uShopOrderButton" should actually be on one of your public pages and will handle transferring customers to your secure "ushop.pl" script when the customer presses it.

That may be causing the problem, because the very first "Referral Check" expects the referrer to be your public server.

Also, just to be sure, make sure that you have question #3 in the ushop.pl script set to:

$store_url = "http://www.rameynet.com/";

and question #4 in the ushop.pl script set to:

$secure_script_url = "https://orchid.site-secure.net/rameynet/cgi-bin/newtools/ushop.pl";

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Thanks Bill Weiner "
Posted by Luis Rosario on Sep-25-00 at 12:31 PM (EST)
Thanks that was the problem

question #3 in the ushop.pl script set to:

$store_url = "http://www.rameynet.com/";

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "Illegal Referrer Page"
Posted by Roger on Nov-03-00 at 05:44 PM (EST)
I just had a customer call in to tell me he got the same message. He was using IE5.5 on a PC. My ordering system is set up correctly on both points mentioned in your reply and usually works fine. However, I still have some customers report the same error. Could there be another reason?
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "RE: Illegal Referrer Page"
Posted by Bill Weiner on Nov-04-00 at 07:44 AM (EST)
Do you know when exactly they were seeing the message? That is, did it occur after the first "review cart" page of the ordering process..... or did it occur at later point in the ordering process.... like after the customer has filled in the billing/shipping address information?

If occuring after the first "review cart" page...then that is point where the Java-side of things is transferred over to the Perl-side of things. So make sure that the URL of the page with your uShopOrderButton applet on it begins with the same URL that you configured as the $store_url in configuration question #3 of the ushop.pl script. And if that doesn't solve the problem, you can always temporarily disable that first referral page validation check by setting the "Referral Page Validation" (General Settings - Miscellaneous) to "NO"....(FYI: That first check is to just prevent someone from saving the HTML pages on their computer and trying to change the prices)..... And then give me the URL and I will take a look at it. (Also let me know what version of the scripts you are using by generating a Diagnostics report).

Otherwise, if the message is occuring at any other point in the order process, then really the only thing there to check is that the URL that you configured as the $secure_script_url in configuration #4 of the "ushop.pl" script matches the URL that you specified for your uShopOrderButton applets "script_url" parameter. That is, make sure they match exactly.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.