www.uburst.com www.uburst.com

"Illegal Referrer Page"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Problems with trying to place orders.
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Illegal Referrer Page"
Posted by Mike Russo on Oct-23-02 at 12:20 PM (EST)
I have seen a few of the postings for this issue of Illegal Referrer Page and still can't seem to fix it using that info. On my site, I click the 'Begin Order Proccess image'. Then I click continue. I then fill out the billing info and click Continue. That's when I get the message 'Illegal Referrer Page - The referring page did not meet security requirements. Press BACK To Continue'. The site is http://www.mrmilitaria.com. The uShop.pl file looks like this:

# 3. What is the URL of your website?
$store_url = "http://www.mrmilitaria.com/";

# 4. What is the secure URL of this script?
$secure_script_url = "https://secondary.lfchosting.com/russo/cgi-bin/ushop.pl";

The control panel was getting the same error, but after talking to my hosting company, they told me to use this address for #4, and it worked. Now, I'm having that same problem with the checkout and they don't know why.

Any help is greatly appreciated.

Mike

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Illegal Referrer Page, Bill Weiner, Oct-24-02, (1)
Thank you, Mike Russo, Oct-24-02, (2)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Illegal Referrer Page"
Posted by Bill Weiner on Oct-24-02 at 04:46 AM (EST)
I took a look at your site at:

http://www.mrmilitaria.com

And I believe I see the problem.

Currently on your "Checkout" page, your uShopOrderButton applet has the "script_url" parameter set to the following:

< PARAM NAME="script_url" VALUE="http://secondary.lfchosting.com/russo/cgi-bin/ushop.pl" >

Try changing that to your SECURE (https) URL:

< PARAM NAME="script_url" VALUE="https://secondary.lfchosting.com/russo/cgi-bin/ushop.pl" >

And that should do it!

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Thank you"
Posted by Mike Russo on Oct-24-02 at 08:59 AM (EST)
That was it. Thank you very much.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.