www.uburst.com www.uburst.com

"illegal referrer"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Problems with trying to place orders.
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"illegal referrer"
Posted by Patrick on Jun-13-01 at 08:32 AM (EST)
Still having trouble with this.

The applet is set to https://secure/mysite.com
The the script is also the same, I can make everthing work fine with the refferer page off, but when I turn it one i get, illegal referrer.

I have read the forum and followed the instructions with one answer to someones problem but did not fix mine.

Thanks

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Illegal Referrer, Joseph Pishgar, Jun-13-01, (1)
illegal referrer error, Jeff Lighthall, Sep-19-01, (2)
RE: illegal referrer error, Joseph Pishgar, Sep-19-01, (3)
RE: illegal referrer, Bill Weiner, Sep-19-01, (4)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Illegal Referrer"
Posted by Joseph Pishgar on Jun-13-01 at 09:32 AM (EST)
Which applet do you have set to "https://secure/mysite.com"? Could you post the code you used here?

Regards,
Joseph Pishgar

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "illegal referrer error"
Posted by Jeff Lighthall on Sep-19-01 at 08:53 AM (EST)
I am also having problem with the illegal referrer error. Like Patrick I followed all instructions in the reference pages for security. In my cgi directory on my secure server I have file permissions set to 733 (700 would not work). When referrer is set to off in the control panel everything works fine, but when set to on I get the error message. Does anyone have any ideas?

Thanks,
Jeff

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: illegal referrer error"
Posted by Joseph Pishgar on Sep-19-01 at 12:22 PM (EST)
Some storefronts have multiple domains, and certain servers do not recognize crossing domains from unsecure to secure, if the domain changes. If it works with the Referrer off, by all means, leave it off. The only issue this could cause is another storefront being setup by someone else, linking to your script, and placing false orders. (Though why someone would take the time to setup a whole seperate storefront just to place false orders is beyond me.) If its an issue, please submit a support request at http://www.uburst.com/supportform.html and we'll troubleshoot it.

Regards,
Joseph Pishgar
Support Engineer
Microburst Technologies, Inc.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "RE: illegal referrer"
Posted by Bill Weiner on Sep-19-01 at 10:11 PM (EST)
Patrick and Jeff:

You must make sure that configuration question #3 at the top of your ushop.pl script (the $store_url) is set to the same domain that your HTML pages are located on.

For example, if your order applet is on the URL/page:

http://www.yourdomain.com/placeorder.html

Then configuration question #3 at the top of your ushop.pl script should be set to:

$store_url = "http://www.yourdomain.com/";

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.