www.uburst.com www.uburst.com

"Problems with the cgi script for 3.0 can send orders"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

CGI Script Related Problems
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Problems with the cgi script for 3.0 can send orders"
Posted by Kridaraan on Oct-14-00 at 06:27 AM (EST)
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:


Can't locate D:/www/citrastore.com.my/cgi-bin/ushop-languages.pl in @INC (@INC contains: d:/Perl/lib d:/Perl/site/lib .) at e:\user\citrastore.com.my\web\cgi-bin\ushop.pl line 52.

it can be checked at: http://www.citrastore.com.my/onlinestore/checkout.html . Please help me. This is really important to our company! I would like to know if chmod is needed. If yes, what is it? I would really appreciate your help.

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Problems with the cgi script fo..., Bill Weiner, Oct-14-00, (1)
Still can't, Kridaraan, Oct-17-00, (2)
RE: Still can't, Bill Weiner, Oct-17-00, (3)
Doesn't work, Kridaraan, Oct-18-00, (4)
RE: Doesn't work, Bill Weiner, Oct-18-00, (5)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Problems with the cgi script for 3.0 can send orders"
Posted by Bill Weiner on Oct-14-00 at 02:21 PM (EST)
Based on your "Can't locate D:/www/citrastore.com.my/cgi-bin/ushop-languages.pl" error, see item number 7 on the following troubleshooting page:

http://www.uburst.com/uShop/troubleshooting.html

That will solve the problem.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Still can't"
Posted by Kridaraan on Oct-17-00 at 01:19 AM (EST)
Sir,
I have tried that way which is putting the full path as shown in the example. But i still can't get it working. I'm using NT server.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: Still can't"
Posted by Bill Weiner on Oct-17-00 at 06:19 AM (EST)
From going to your script at:

http://www.citrastore.com.my/cgi-bin/ushop.pl

I can see that you are now getting the error message:

"Can't locate D:/www/citrastore.com.my/cgi-bin/ushop-languages.pl"

That is, it looks like you have configuration question #11 set to:

require "D:/www/citrastore.com.my/cgi-bin/ushop-languages.pl";

Are you sure that is the correct path for your server? Based on your error messages, I would guess you should be using:

require "e:/user/citrastore.com.my/web/cgi-bin/ushop-languages.pl";

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "Doesn't work"
Posted by Kridaraan on Oct-18-00 at 02:42 AM (EST)
I've tried using e: but it still doesn't seem to work. You can check it at: www.citrastore.com.my/onlinestore/checkout.html .
And i would also like to know if i must chmod a folder like the version 2.0 one. We need to finish this order project by next thursday and i will get real scolding from my manager for wasting money getting this program which doesn't work. I really need your help and this is urgent!
S.O.S. I've also spent lots of time setting up the store and the only damn thing that isn't working is the cgi. Can i've your e-mail add? I can send you the cgi and you can inspect it. Would that be fine? Or is it better checking it online. I really need a reply as soon as possible. This is very important to our business!

Thanks,
Kri

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . "RE: Doesn't work"
Posted by Bill Weiner on Oct-18-00 at 05:16 AM (EST)
By going to your script at:

http://www.citrastore.com.my/cgi-bin/ushop.pl

I see you are now getting different error messages such as:

"not returning a complete set of HTTP headers"
"Bareword found where operator expected"
"syntax error near near "$settings_file = $data_directory . "ushop"
"Missing semicolon on previous line"

Which definitely means you made an error while configuring the script... most likely by in configuration question #6...which shouldn't be modified anyway.

If you want, send your "ushop.pl" file to support@uburst.com and I will take a look at your configuration questions.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.