www.uburst.com www.uburst.com

"Script Error on the UShop 3.0"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

CGI Script Related Problems
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Script Error on the UShop 3.0"
Posted by Paul Abernathy on Aug-04-00 at 09:05 PM (EST)
I would like anyone who can help me fix the (Unable to open ./data/ushop-settings.txt) problem I am having with uShop3.0. I have checked the CHMOD and its at 700 and I have tried it at 755 also. and I have it set at ./data/ as listed and have even put the templates in the ./data/ folder and still do not know why I am getting that error.. Can anyone HELP a fella:)

Paul Abernathy
RadioPet.Com

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Script Error on the UShop 3.0, Bill Weiner, Aug-05-00, (1)
Thanks Bill....it works fine now!, Paul W. Abernathy, Aug-15-00, (2)
RE: Thanks Bill....it works fine no..., Bill Weiner, Aug-15-00, (3)
Order Button....Needed As soon as p..., radiopet, Aug-15-00, (4)
RE: Order Button....Needed As soon ..., Bill Weiner, Aug-16-00, (5)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Script Error on the UShop 3.0"
Posted by Bill Weiner on Aug-05-00 at 06:54 AM (EST)
That problem will usually be related either 1) the path to your data directory being incorrect or 2) the permissions of your data directory being incorrect. (http://www.uburst.com/uShop/troubleshooting.html#UNABLETOOPEN1)

It sounds like you already double/triple-checked the permissions on that directory....so it may have to do with your path to your data directory. That is, "./data/" may not work on your server. Sometimes a full directory path must be used.

Since you've used uShop 2.0 before, the easiest thing to do might be to just look at your current ushop_cgiscript.pl file and see what you are using for the $order_directory (question #10 in that 2.0 script). That is, the "data" directory in uShop 3.0 is equivalent to the "orders" directory in uShop 2.0.... so perhaps just compare the directory path and permissions with your working uShop 2.0 and that may resolve the problem.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "Thanks Bill....it works fine now!"
Posted by Paul W. Abernathy on Aug-15-00 at 05:39 PM (EST)
Bill,

Thanks again for the wonderful help, I simply used the orders file as it was in the 2.0 version and it worked fine..I did however have to set the Chmod to 777 for it to work...but now it works fine...Only trouble I have now is the "begin the Order Process" button does not actually fad in and out like the applet buttons..this would be awesome as clients could physically see it doing something..but they just dont seem to wanna click the image. Other than that....3.0 ROCKs!
Paul W. Abernathy,CEO
RadioPet.Com

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: Thanks Bill....it works fine now!"
Posted by Bill Weiner on Aug-15-00 at 07:24 PM (EST)
Glad that worked for you.

As for the "Order Button" showing some movement in order to indicate that it has been pressed, it shouldn't be too difficult to make a "button" version of that applet. We'll see about getting that into a future update.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "Order Button....Needed As soon as possible"
Posted by radiopet on Aug-15-00 at 11:10 PM (EST)
Bill,

I am getting call after call with people not knowing how to order on-line..now from what I gather the java applet that lists the " Example_order_button.gif is not loading the image for the clients and they dont know how to start the process....It seems that AOL users are having the most trouble. Can a special applet be requested so that they also have a button to start the process also...just a java button or something to help these clients out and me also.

Paul Abernathy,CEO
RadioPet.Com

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . "RE: Order Button....Needed As soon as possible"
Posted by Bill Weiner on Aug-16-00 at 05:47 AM (EST)
See:

http://www.uburst.com/dcforum/ushp_general_purpose/60.html

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.