www.uburst.com www.uburst.com

"CGI/perl.exe"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

CGI Script Related Problems
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"CGI/perl.exe"
Posted by Brad Giosa on Jul-07-00 at 05:02 PM (EST)
ok i am running my own win2k server and i have my chopping cart in wwwroot/cgi-bin. everything is contained inn that folder. i downloaded Activeperl. and i set the script properties in IIS 5.0 to .pl -->c:\perl\bin\perl.exe and
.cgi---> c:\perl\bin\perl.exe and when ever i try to test my ordering everything works except the command just hangs nothing happens. i even went to the command line and type: perl ushop_cgiscript.cgi (also tried pl) with the cmd=write and all that and all it does is hang nothing happens. is there anyone who can help??
thanks brad giosa
please reply by emailing me bboyizmo@aol.com
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: CGI/perl.exe, Bill Weiner, Jul-08-00, (1)
cgi/perl.exe, brad g., Jul-08-00, (2)
RE: cgi/perl.exe, Bill Weiner, Jul-10-00, (3)
perl/cgi mapping, brad g, Jul-10-00, (4)
RE: perl/cgi mapping, Bill Weiner, Jul-10-00, (5)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: CGI/perl.exe"
Posted by Bill Weiner on Jul-08-00 at 08:13 AM (EST)
If you've never executed Perl scripts on your server before, I would suggest that you try installing the very basic Perl script described at:

http://www.uburst.com/uStorekeeper/testscript.html

This test script is actually on the reference pages for one of our other products (called uStorekeeper), but the concept is the same. By following the instructions to install this very basic Perl script, you should be able to see how Perl scripts are installed/executed on your server, as well as verify that it is indeed setup properly to execute Perl scripts. Once you get that test script working....installing the uShop CGI script should be much easier.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "cgi/perl.exe"
Posted by brad g. on Jul-08-00 at 04:16 PM (EST)
ok i did everythingng it told me too. still doesn't show a test page. could it be that my iis 5.0 setting are wrong or not installed properly?
in iis 5.0 i have the .pl document point toward c:\perl\bin\perl.exe. is this correct or are my server settings incorrect???
brad
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: cgi/perl.exe"
Posted by Bill Weiner on Jul-10-00 at 06:33 AM (EST)
If the very basic test script doesn't run on your NT server, then the server settings may indeed be wrong. Unfortunately, Iím not really familiar with configuring NT servers, but perhaps this excerpt from someone else configuring an NT server will help:

"For those of us who run our own NT servers, you might consider adding this to your troubleshooting area... If the script tries to download (or is displayed) rather than ran. You say the directory may not be configured to run CGI scripts. And that is true, however the directory must have execute permission, but the site is what must be configured to execute scripts by mapping the perlis.dll to each site that will use it. At site root directory in IIS Console, properties, home directory tab, configuration, App Mappings tab, add. This is true for both IIS 4 on NT 4.0 and IIS5 on Windows 2000 beta."

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "perl/cgi mapping"
Posted by brad g on Jul-10-00 at 10:02 AM (EST)
i have tried to map the .pl and .cgi files at the root of my dir in iis 5.0 and scripts and executables are enabled, i have the following mapped:
.pl mapped to c:\perl\bin\perlis.dll
.cgi mapped to c:\perl\bin\perlis.dll
the does not download and does not show, it only hangs on my browser as if it is doing something.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . "RE: perl/cgi mapping"
Posted by Bill Weiner on Jul-10-00 at 03:13 PM (EST)
Glad to hear you figured out the problem:

http://www.uburst.com/dcforum/ushop_place_order/61.html

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.