www.uburst.com www.uburst.com

"unable to locate order page"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

CGI Script Related Problems
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"unable to locate order page"
Posted by webgeek on Jun-08-00 at 02:50 PM (EST)
Hi, I am testing Ushop on another site. They want to see it before they buy it. Any how I am referencing one of my other site's class directory for the codebase of their scripts. The scripts run just fine, but when I go to the order page I get a "unable to locate order page" error. Funny thing is the order.template page DOES exist in that directory that the script is looking in (and it works). Is this a protective feature of Ushop? If so, great! If not, any ideas why this isn't showing up?

Details:
URL http://www.webgeekdesign.com/mad/
SSL https://webgeek2.virtualis.com/mad/order.template

I have tried both the relative and direct URL without success in the "order_page value="

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: unable to locate order page, Bill Weiner, Jun-09-00, (1)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: unable to locate order page"
Posted by Bill Weiner on Jun-09-00 at 05:15 AM (EST)
From looking at your website, I notice that you have the "scriptpath" parameter of your uShopOrderButtonCGI applet set to:

https://webgeek2.virtualis.com/cgi-bin/mad/ushop_cgiscript.pl

And you have the "order_page" parameter of that applet set to:

../htdocs/mad/order.template

The problem may just be that since you have the script located in a subdirectory of your cgi-bin subdirectory (cgi-bin/mad/), you just need an extra "../" in your path to get to the order template located in the "mad" subdirectory of your main HTML directory. So in other words, try changing the order_page parameter to:

../../htdocs/mad/order.template

And that may fix it. Otherwise, go ahead and try the full path to that directory (not the full URL)...it will be something like:

/www/htdocs/mad/order.template

But in anycase, provided your order.template file is located on the same server as your ushop_cgiscript, then the ushop_cgiscript should be able to load it....just a case of getting the directory path right.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.