www.uburst.com www.uburst.com

"500 internal Server error"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

CGI Script Related Problems
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"500 internal Server error"
Posted by brgreene on May-15-01 at 09:20 PM (EST)
I get the following error when trying to access the script in 3.4:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@safe-order.net and inform them of the time the error occurred, and anything you might have done that may have caused the error."

I've tried setting permissions 755 and 777. I have made sure transfered in ascii mode. The test script works fine.


https://mpcinternetworks.com/ssl/heartlandbraidedrugs/cgi-bin/ushop.cgi
Produces the error

https://mpcinternetworks.com/ssl/heartlandbraidedrugs/cgi-bin/cgitest.cgi
Works

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: 500 internal Server error, Bill Weiner, May-15-01, (1)
500 internal Server error, Paul, Nov-16-01, (2)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: 500 internal Server error"
Posted by Bill Weiner on May-15-01 at 10:48 PM (EST)
Have you tried all of the suggestions listed in item #2 on the troubleshooting page?

http://www.uburst.com/uShop/troubleshooting.html

If so and you still get a server error, then I would suggest these steps:

1) Try starting over with a fresh copy of the uShop scripts (ushop.pl, ushop-lib.pl, ushop-languages.pl)... just to make sure no errors were accidentally introduced when initially configuring the scripts.

2) When checking permissions, make sure to give all 3 scrips read & execute permissions (chmod 755).

3) If still getting the server error, on some extremely rare server configurations... the path to perl had to be added to the top of the ushop-lib.pl file and the ushop-languages.pl file... in addition to the ushop.pl file. So maybe try adding the path to perl on the first line of your ushop-lib.pl and ushop-languages.pl files... just as the path to perl was specified in your ushop.pl file.

4) And if you are still getting a server error, then send us your scripts at support@uburst.com... and I'll take a look at them and see if I can spot the problem.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "500 internal Server error"
Posted by Paul on Nov-16-01 at 03:19 PM (EST)
it looks like it works. but if i am mistaken then you might want to check the CHMOD and change the numbers/permition.
Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.