www.uburst.com www.uburst.com

"Primary email notification failure"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

CGI Script Related Problems
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Primary email notification failure"
Posted by James on Nov-09-00 at 10:33 PM (EST)
Hi,
I have had reports from two clients on unix that the primary notifications are not working. The secondary notifications work just fine. All settings are correct.

Any ideas would be appreciated, great cart, just wish the java didn't eat up the resources causing browser crashes, typically just during development.

Thanks,
James

Click to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Primary email notification fail..., Bill Weiner, Nov-10-00, (1)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Primary email notification failure"
Posted by Bill Weiner on Nov-10-00 at 06:36 AM (EST)
As a test, I would suggest trying to use a different email address for the primary email address.... perhaps one of the secondary email addresses that was definitely working. This would help determine if the problem is just the email address itself. That is, the server may be configured to not send email outside of it's own domain (for spamming reasons).... Or may just be looking up that domain incorrectly (like thinking it is hosted on that server when it is really hosted externally - something that seems to happen sometimes for domains that were formally hosted on a server but then was transferred elsewhere).

If you do find that it is just a problem for particular a domain name (or names), then you should be able to show that to your web hosting provider and they should be able to help with getting that domain mapped correctly.

Or as another option, instead of using sendmail on your UNIX server to send email, then you could try using the SOCKETS email option to send mail from your mail server. See instructions below:

To use SOCKETS instead of sendmail:

STEP 1) Open the "ushop.pl" file and change configuration question #7 to:

$email_method = "SOCKETS";

STEP 2) Also in the "ushop.pl" file, make sure you specify the ip address of your mail server in configuration question #10.

STEP 3) And since you have a UNIX server, I would also suggest opening the "ushop-lib.pl" file and about 29 lines down from the start of the page you will see these five lines:

#use Socket;
#$AF_INET = AF_INET;
#$SOCK_STREAM = SOCK_STREAM;
$AF_INET = 2;
$SOCK_STREAM = 1;

Change these lines by uncommenting the first 3 and commenting out the last 2, like this:

use Socket;
$AF_INET = AF_INET;
$SOCK_STREAM = SOCK_STREAM;
#$AF_INET = 2;
#$SOCK_STREAM = 1;

(So that the "Socket" lib is used to send email from your UNIX server.)

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.