www.uburst.com www.uburst.com

"uShopCart don't display"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Applets are not being displayed
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"uShopCart don't display"
Posted by Jan Swartling on Sep-08-00 at 12:58 PM (EST)
Thank you for helping out with one of the other questions I had. Now its time for the next one.

Using uShop v2, swedish version.

I am using the applet 'uShopCart_se.class' but quite frequently it is not loading properly when viewed using Netscape (v4.61 Windows version). I have not found this behavior in Internet Explorer (v5.0). This problem apply when I use the 'COUNT' function. If I move the mouse over the area where the "count" should show, the browser status line says 'applet uShopCart_se initialized' when the applet failed to load. The status line show 'applet uShopCart_se running' when it loaded correctly.

This behavior is very frequent, I'll say the applet fail rate is 80%. I think it have something to do with the size of the applet in combination with the allocated area for the applet. I have experimented with different size settings (width and height), but every time I think I have found some logic in the behavior it fails again. It might also have something to do with the fact that it is placed within a table cell. I have also tried to set the table widht parameter, but still no luck.

Below you will find excerpts from the Netscapes Java Console ('communicator/tools/Java Console') using the 'd: command' (dump applet context state to console). I have just cut/pasted the relevant lines:

When applet load OK this lines are showing:

# Active applets and applet contexts:MozillaAppletContext id=2 #frames=1 #images=0 #audioClips=0 url=http://localhost/shop/logo.html EmbeddedAppletFrame id=14908000 applet=uShopCart_se[panel0,0,0,40x20,layout=java.awt.GridBagLayout]

When applet dont load OK

# Active applets and applet contexts:MozillaAppletContext id=2 #frames=1 #images=0 #audioClips=0 url=http://localhost/shop/logo.html EmbeddedAppletFrame id=14921392 applet=uShopCart_se[panel0,0,0,40x20,hidden,layout=java.awt.GridBagLayout]

As you can see the different is that the applet is marked 'hidden' when the applet does not load OK. Its is important to point out that this random behavior occur even when the width and height have their default value (40 x 20) as in the excerpts above.

I hesitate to put the failing web page on line (I use a remote ISP) because potential loss of customers if they find that the order process not working as expected, but I can do it if you think it will help in problem solving.

I have read and tried your suggestions to others with similar or near similar experiance.

I would appreciate your comments?


Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: uShopCart don't display, Bill Weiner, Sep-08-00, (1)
uShop Cart don't display, Jan Swartling, Sep-12-00, (2)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: uShopCart don't display"
Posted by Bill Weiner on Sep-08-00 at 06:01 PM (EST)
I could tell better if I could see the page.... but what other applets do you have on that page?

Do you have the order applet on that page too? And/or do you have multiple shopping cart applets on that page? If the answer is "yes" to either of those questions.... then combined with the fact that you are just seeing the problem with Netscape.... then I would say it sounds like the Netscape bug that we discoved back in February and developed a work-around that was released on 2/17/00 at:

http://www.uburst.com/uShop/updates.html

Unfortunately, we only implemented that work-around in the English versions of uShop... and now that we have released uShop 3.0.... I don't think we were going to bother going back to implement the work-around in the international versions of uShop 2.x. But since we are still waiting on the Swedish translations for uShop 3.0 and I'm not sure when we'll get them... go ahead and submit a support request and we'll see what we can do for your Swedish version of uShop 2.x.

Until then, if possible for your Swedish version of uShop 2.x, just try keeping one shopping cart applet per page... and don't put a both a shopping cart applet and an order applet on the same page.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "uShop Cart don't display"
Posted by Jan Swartling on Sep-12-00 at 01:09 PM (EST)
Bill,

Just wanted to let you know that the problem is solved. As you
correctly pointed out I had both an order applet (uShopOrder3CGI_se) and a hidden cart
applet (uShopCart_se) on the same page. Although they were placed in different
tables in different frames on the page, that didn't seem to work. When I
changed the layout of this particular page in a way that made it possible
to remove the order applet, it all worked as it should and all remaining applets
loaded OK.

The reason I had both the order applet and the cart applet on the same
page was because you in response to an earlier question (a couple of
months ago) suggested this as a solution to get VAT and Shipping cost to
display in the uShopOrder applet without first going to the 'real' order
applet. This method does work on another test page I have where the cart
applet is in a table and the order applet is outside the table.

I don't know, maybe it's a combination of putting the two applets in
tables on framed page that creates the problem.

Anyway, I changed the layout of the page in question and it works. I will
not submit a support request, at least not until I tested the Swedish
version 3.

The page is on 'www.bluesoft.se/shop/shopv4.html'

Thank for your support.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.