www.uburst.com www.uburst.com

"No Applets are showing"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Applets are not being displayed
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"No Applets are showing"
Posted by jalina on Sep-01-00 at 09:41 AM (EST)
I have been racking my brain for days now trying to find what is wrong. This is the error msg I have been getting
Applet uShopCart error:java.lang.NoClassDefFoundError

It was all working fine before and now suddenly none of them are working

Here is the addy if you want to take a look.
http://www.eroticromance.com/videos/bondage/master/master.html

Thank you for your time

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: No Applets are showing, Bill Weiner, Sep-01-00, (1)
No Applets are showing, jalina, Sep-01-00, (2)
RE: No Applets are showing, Bill Weiner, Sep-01-00, (3)
No Applets are showing, jalina, Sep-01-00, (4)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: No Applets are showing"
Posted by Bill Weiner on Sep-01-00 at 10:55 AM (EST)
I took a look at your uShop 2.x site and noticed the following errors in the Java Console:

java.lang.NoClassDefFoundError: uShopCartBase
java.lang.ClassNotFoundException: uShopProducts
java.lang.ClassNotFoundException: uShopLibrary

....which is a good indication that you don't have all of the "required" uShop class files on your server.

So then I took a look at your classed directory at:

http://www.eroticromance.com/cgi-docs/

And can indeed see that the following required class files are missing:

uShopCartBase.class
uShopLibrary.class
uShopProducts.class
uShopMessageWindow.class

So try transferring those class files to your server and that should correct the problem.

Note that you can see a listing of all required class files in the "Required Applets" section of the uShop 2.x applet reference:

http://www.uburst.com/uShop/reference2/us/

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "No Applets are showing"
Posted by jalina on Sep-01-00 at 12:22 PM (EST)
Thank you for answering so quickly.
I have added the files that you listed that were missing. Unfortunatly it is still not working for me.
They at one time were working and then for some reason unknown to me they stopped. I am truely getting frustrated with this. Could you please take another look at it for me, I would greatly appreciate it.

Thank you for your time.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "RE: No Applets are showing"
Posted by Bill Weiner on Sep-01-00 at 01:59 PM (EST)
I took another look at your site and can now see the following error message being displayed in the Java Console:

"java.lang.NoSuchMethodError: uShopProducts: method checkTrialVersion ()Z not found"

...this error message is a good indication that you have some of the uShop 2.x trial version class files and some of the uShop 2.x full version class files on your server. It is extremely important not to mix the class files of the trial version and the full version.

To correct it, I would suggest deleting ALL of the class files from your server...and then re-transfer all of new class files to your server.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "No Applets are showing"
Posted by jalina on Sep-01-00 at 05:36 PM (EST)
Okay that fixed it and I feel like a bit of a dolt but at least its working now :)
Thank you so much for your time and help. With my knowledge of this stuff I am sure we will be talking again soon :)

Thank you again
jalina

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.