www.uburst.com www.uburst.com

"Secure Applets Greyed out"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Applets are not being displayed
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Secure Applets Greyed out"
Posted by David on Mar-17-00 at 01:40 PM (EST)
My customers are all complaining when they try to make an order, they see grey boxes using Netscape 4.7 and IE 5.0 and IE 5.01 on my UNIX system with Ushop 2.0 . I have no problems and thought if they upgrade to IE 5.01 that would take care but they swear it's grey boxes still. Some can see it fine like me, while others don't. What is this "some do, some don't" deal? I can whip back and forth and not have greyed boxes. I have NO CODEBASE, because all of the files are in the same directory. It's just the secure pages. I have put the large display cart on top of the creditcard fill out page so they can see how much their order is costing them with shipping and tax. No codebase for either, same directory as class files. What gives?
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

applets grayed, Charlie Edmunds, Mar-17-00, (1)
greyed applets, Charlie Edmunds, Mar-17-00, (2)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "applets grayed"
Posted by Charlie Edmunds on Mar-17-00 at 08:12 PM (EST)
David,

How long have you had your site up? We had a problem with Netscape browsers 4.7 and up when the cart was on the same page with the order applet. If you downloaded uShop over a month ago then download the latest copy. Delete your class files and replace them with the new ones. You do not need to do anything to your existing cgi script. If that does not work send me an url so I can look at your site.

Charlie Edmunds

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "greyed applets"
Posted by Charlie Edmunds on Mar-17-00 at 08:25 PM (EST)
Try this first David,

2.4 Applets do not appear on the Secure Order Page

If the order page on your server is successfully being found, but the applets are not being loaded on the order page, then the problem is usually that your codebase parameter on your order page is missing or is incorrect. For the applets on your secure order page, You must specify the CODEBASE parameter. That is, in order to find your classes on the secure server, you must specify the CODEBASE parameter of all applets on the secure order page. This codebase parameter must be the FULL URL of the classes. For instance, if you put all of the uShop .class files in a directory called "classes" on your public server, then you would specify the codebase parameter of the applets on your server as something like this:

codebase="http://www.yourdomain.com/classes/"

So your order applet would be something like this (Note the CODEBASE parameter in the first line):


Charlie Edmunds

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.