www.uburst.com www.uburst.com

".class files don't load"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Applets are not being displayed
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
".class files don't load"
Posted by Brian on Nov-03-99 at 03:17 PM (EST)
Seems edmund and I have the same problem. I have looked at his site and has made no dif. The thing that is driving me nuts is that they all once worked. When I entered the personal information into the form and submitted I received a message that I needed to add items to the cart-had one in it. I then found out that I had to use the ordercgibutton.class for my setup. I added this to the bottom of my shoppingcart.html and this is when my problems started. Now none of my ushopinputstandard applets load in this directory.
http://www.elitemall.com/chocolates/
Any help greatly appreciated.
Brian
Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

Class Files not loading, Charlie Edmunds, Nov-03-99, (1)
I received a message that I needed ..., Sommay, Nov-03-99, (2)
I received a message, Brian, Nov-04-99, (3)
uShopOrderButton.class, Sommay, Nov-04-99, (5)
uShoporderButton.class, Brian, Nov-04-99, (6)
class files not loading, Brian, Nov-04-99, (4)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "Class Files not loading"
Posted by Charlie Edmunds on Nov-03-99 at 07:36 PM (EST)
Brian,

take a look at the documentation below. It has a lot of good info for handling class files. The problem you are describing is almost always caused by how the class files are referenced. I was unable to get your site to come up. Are you using the codebase parameter? All your applets should have the class file location referenced the same way.

http://www.uburst.com/uShop/reference/codebase.html

Read over this materail and see if it helps you. If not post again and let me look at your pages.

Charlie Edmunds
Project Manager
Microburst Technologies, Inc.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "I received a message that I needed to add items to the cart-had one in it"
Posted by Sommay on Nov-03-99 at 11:24 PM (EST)
When I entered the personal information into the form and submitted I received a message that I needed to add items to the cart-had one in it. I am using the trial version I dont think I have ordercgibutton.class file. If I do have it where do I add this file to?

Sommay
http://www.blackchips.com/fmain.html

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "I received a message"
Posted by Brian on Nov-04-99 at 03:38 PM (EST)
Sommay,

This message is exactly what I am dealing with right now. The ordercgibutton.class is included in both trial and full versions. If for some reason you don't have try downloading another copy of the zip file. The reason we got the add items to the cart message is that (as I understand it) is that we are both setup with our html pages on the public server and running our script through our secure servers; https://www.etc.com. In order to do this we must use the uShopOrderButton.class file to transfer the unsecured shopping cart information to the secure server. This file needs to be placed on the form you are using as your shopping cart.

Hope this helps.
Brian

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . "uShopOrderButton.class"
Posted by Sommay on Nov-04-99 at 06:26 PM (EST)
Brain and Charlie, Thanks for your responce. I am lost still! I'm not run anything on secure server at this time, I really dont understand what you mean! I'm not sure where and how to put uShopOrderButton.

Brain can I have your URL so I can look in View Source. Oh what is https://www.etc.com

Sommay

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
6 . "uShoporderButton.class"
Posted by Brian on Nov-04-99 at 06:47 PM (EST)
Sommay

http://www.elitemall.com/chocolate

This is my url for a product on my site. When you get here you will see an ftp type page with three links, classes, images, and produc~1. You may browse as you see fit. https://www.etc.com is am example only. Purchases on-line should only be done in a secure manner. Anything else will asking for trouble if the information is intercepted. For instance my public and secure servers are actually the same machine. To reach the url I gave you above in a secure fashion would be https://www.olywa.net/elitemall/chocolate. Olywa.net is my server and my transaction is secured using their certificate. I haven't looked into the smtp .class files yet but you may want to and see if this will fill your order processing needs if you don't want to use the https: method.
Sorry for any confussion.
Brian

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "class files not loading"
Posted by Brian on Nov-04-99 at 03:48 PM (EST)
Charlie,

Thanks for your responce. Seems that I put one to many s' on the url that I left you yesterday, sorry. Anyway, the problem seems to be on my computer not the cart. Next issue however, is that the ushop_cgisript.pl is not working for me. My server (NT4 with IIS4 and Activestate newest perl)does not require that I specify the path to perl. I have been to the trouble shooting page, faq, user manual, and now here. I get a eneric server error message when I try to access the .pl file. I am fairly certain that the information I supplied for it is correct. If I specify a path to perl in this program and it is not reqired will this cause an error. If it will how do I comment it out or can I simply delete it. Any other ideas most welcome.
Thanks,
Brian

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.