www.uburst.com www.uburst.com

"uDirectory Deluxe"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

uDirectory Configuration Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"uDirectory Deluxe"
Posted by Norm on Nov-09-99 at 04:02 PM (EST)
Installed on apache server under bsd.

following msg in error log (truncated here)
syntax error in file /usr/local/etc/httpd/cgi-bin/udirectory.pl at line
878, next 2 tokens "my ("
syntax error in file ....
.... at line 2490, next 2 tokens "my ("
/usr/local/etc/httpd/cgi-bin/udirectory.pl has too many errors.
[Mon Nov 8 15:23:16 1999] access to
/usr/local/etc/httpd/cgi-bin/udirectory.pl failed for 216.64.3.87,
reason: Premature end of script headers

Where should I look?

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

cgi script error, Charlie Edmunds, Nov-09-99, (1)
One More thing to check, Charlie Edmunds, Nov-09-99, (2)
One More thing to check, Norm, Nov-18-99, (3)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "cgi script error"
Posted by Charlie Edmunds on Nov-09-99 at 04:52 PM (EST)
Hi Ron,

What kind of editor did you use to edit and save the script? If it was not saved in 'unix' format I have seen it cause problems. There is a difference between how unix and windows handle line feeds and it can cause all kinds of strange errors.

Charlie Edmunds
Project Manager
Microburst Technologies, Inc.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . "One More thing to check"
Posted by Charlie Edmunds on Nov-09-99 at 07:27 PM (EST)
Norm,

What version of perl are you using? It should be version 5.

Thanks, Charlie

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "One More thing to check"
Posted by Norm on Nov-18-99 at 04:53 PM (EST)
Yes, that was the problem. Perl4 and 5 are available and I was pointing the script to 4.

Thanks

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.