www.uburst.com www.uburst.com

"Getting closer..."

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

uDirectory Configuration Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Getting closer..."
Posted by Bruce Higgins on Oct-04-00 at 04:24 PM (EST)
Hi Bill and thanks for the quick response! I finally figured out a piece of the puzzle. I had to go into IIS 4 and add the .pl extension to IIS. I found this information at the activeperl.com website. Here is the information they gave on the subject:

How do I configure Microsoft IIS 4.0 to support ActivePerl?
Microsoft IIS 4.0 ships with Windows NT Server 5.0, and PWS 4.0 ships with Windows NT Workstation 5.0. Both IIS and PWS are available as part of the Microsoft Windows NT 4.0 Option Pack. You can find a link to the Option Pack at http://www.microsoft.com/iis/

To configure IIS or PWS 4.0 to run Perl scripts:

1)Open the IIS 4.0 Internet Service Manager. This will bring up the Microsoft Management Console with the Internet Service Manager snap-in selected.

2)From the tree display on the left, select the level at which to apply the mappings. You can choose an entire server, web site, or a given virtual directory.

3)Select Properties from the Action menu.

4)If you chose to administer the properties for the entire server, the Server Properties dialog will appear. Select WWW Service from the Master Properties pull-down menu and click the Edit button under Master Properties. This opens WWW Service Master Properties. Select the Home Directory tab and proceed to step 7.

5)If you chose to administer the properties for an entire web site, the Web Site Properties sheet appears. Select the Home Directory tab and proceed to step 7.

6)If you chose to administer the properties for a virtual directory, the Virtual Directory Properties sheet appears. Select the Virtual Directory tab and proceed to step 7.

7)Click the Configuration button. This opens the Application Configuration dialog.

8)Select the App Mappings tab and click the Add button. You see the Add/Edit Application Extension Mapping dialog.

9)To run Perl as a CGI application, type the full path to Perl.EXE followed by %s %s. When a script is executed, the first %s will be replaced by the full path to the script, and the second %s will be replaced by the script parameters.

10)To run Perl for ISAPI, type the full path to PerlIS.DLL. The %s %s is not required for ISAPI DLLs.

11)In the Extension field, type .pl or .plx (or whatever extension you want to use).

12)The application mapping is now complete. Click the OK button and click OK to dismiss any remaining dialogs/property sheets.

13)Close the IIS 4.0 Internet Service Manager.

Well, this worked fine but I couldn't use the directory name to access the program (www.companyname.com/listings) but could access the program by typing the exact location of the .pl file (www.companyname/cgi-bin/udirectory_personal.pl). The program launched and the password box appeared.! Hurray! Some progress! However, when I typed in my password, I got the message:

FILE ERROR
Unable to open ../listings/listings-A.html

I followed your instructions on changing the relative path but that didn't work either. The directory has RWE permissions too. I checked the directory for any .tmp or other files but there were none. Odd.

Well, please let me know what you think.

Bruce

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Getting closer..., Bill Weiner, Oct-05-00, (1)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Getting closer..."
Posted by Bill Weiner on Oct-05-00 at 07:01 AM (EST)
Thanks for the detailed information about configuring your NT server to execute Perl scripts... I'm sure it will help others who are in the same situation.

As for that "Unable to open ../listings/listings-A.html" error. Check out the "unable to open" troubleshooting tips in section 6 of the uDirectory Personal Edition user's guide:

http://www.uburst.com/uDirectory/personal_users_manual.html#ID

What may be the problem is that configuration question #2 should actually be:

$relative_directory = "../directory/";

instead of

$relative_directory = "../listings/";

... Since I believe you mentioned before that you called your listings directory "directory".

Otherwise, what you may have to do is specify the FULL directory path to your listings directory, such as:

$relative_directory = "C:/users/listings/";

... or whatever the path is on your NT server.

It seems that using the full directory path there is often the easiest thing to do for NT servers.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.