www.uburst.com www.uburst.com

"Illegal referer"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Troubleshooting Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Illegal referer"
Posted by David Schrimpf on Aug-15-01 at 10:19 AM (EST)
I have a client using the ureserve 1.01 script that I set up. They have been using it for a few months with no problems but today they started getting this illegal referer error.

They click on the name of the resource to bring up the small window. They fill in the appropriate information and click the "Reserve" button. That is when the error appears.

I just noticed that when you click on the name of the procedure on a certain day, it adds "#DAY2" to the URL. Could that be causing the illegal referer?

For what it's worth, it works perfectly from my location every time, but hasn't worked for them at all today.

Thanks in advance for any help

Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

Re: Illegal referer, Joseph Pishgar, Aug-15-01, (1)
"Re: Illegal referer", David Schrimpf, Aug-15-01, (2)
Re: Illegal referer, Joseph Pishgar, Aug-15-01, (3)
Re: Illegal referer, Bill Weiner, Aug-16-01, (4)
"Re: Illegal referer", David Schrimpf, Aug-16-01, (5)
""Re: Illegal referer&quo..., David Schrimpf, Aug-16-01, (6)
"""Re: Illegal refer..., David Schrimpf, Aug-16-01, (7)
Re: Illegal referer, Bill Weiner, Aug-17-01, (8)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "Re: Illegal referer"
Posted by Joseph Pishgar on Aug-15-01 at 12:33 PM (EST)
Hello David,

Could you provide us with a URL to check the site out at?

Sounds like something browser-related.

Regards,
Joseph Pishgar

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
2 . ""Re: Illegal referer""
Posted by David Schrimpf on Aug-15-01 at 01:35 PM (EST)
I emailed support@uburst.com with the URL. I didn't want to post it in a public place.

Thanks for checking it out.

If it helps, I have tried it with the following browsers:

IE5 / Mac
Netscape 4.77 Mac

IE 5.5 (AOL version) on Windows 98

and had no problems. I haven't been able to duplicate the problem from my two locations, but they have duplicated it from two different locations.

Thanks.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
3 . "Re: Illegal referer"
Posted by Joseph Pishgar on Aug-15-01 at 02:47 PM (EST)
Thats odd.
Could you have them send you a more detailed report of exactly what it is they are doing, as well as browser version and computer platform.

Sometimes macs or netscape interpret things differently. If we can reproduce the error we can diagnose it.

-Joseph Pishgar

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
4 . "Re: Illegal referer"
Posted by Bill Weiner on Aug-16-01 at 05:10 AM (EST)
The first thing I would check is that they are linking to your site/script via the exact same URL that you configured in configuration question #5 ($script_url). That is, if that URL has the "www" in it...then make sure they are linking with that "www" in it. Or if your script is on a public server... make sure they are not linking via "https".

Otherwise, yes, it would be helpful to know what browser/OS they were using when they get the "illegal referrer" error.

And it would also be helpful to know if they also got the error when just moving to different weekly schedules (via the "Next" and "Previous" buttons). Or was it just when trying to make a reservation?

But in any case, what you can do for now is to disable the referring page check by following the instructions below. That referral check is just an extra security precaution... but is not necessary since we validate ALL USER INPUT anyway.

INSTRUCTIONS TO DISABLE THE REFERRER CHECK IN URESERVE 2.0
---------------------------------------------

STEP 1: Make a backup of your current ureserve.pl script...just in case.

STEP 2: Open your ureserve.pl script with any text editor such as WordPad.

STEP 3: Do a "search" in script for the line that starts with the following text:

&missing_input("Illegal Referrer Page"

(There is only one occurance of that line).

STEP 4: Comment that line out by adding a "#" sign in front of it, like this:

#&missing_input("Illegal Referrer Page"

STEP 5: Save the script (as TEXT if your editor asks)... and try it out!

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
5 . ""Re: Illegal referer""
Posted by David Schrimpf on Aug-16-01 at 11:44 AM (EST)
Thanks for the replies.

I'm trying to get the platform/browser info out of them and I'll post it here when I get it. I'm pretty sure they are at the exact same URL as I entered in question #5, but I will check on the https thing.

Meanwhile, I am using the 1.01 version of the script which you emailed me and which displays times in normal 12 hour time. I'll try commenting out that same line and see what happens, but if you have different instructions for this version, please let me know.

Thanks again for all your help.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
6 . """Re: Illegal referer"""
Posted by David Schrimpf on Aug-16-01 at 11:57 AM (EST)
I forgot to mention that they also get the error when they click the "Next week" and "Previous week" buttons.

I just commented out that line in my version of the script and the script still works for me... I'm going to have them try it now.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
7 . """"Re: Illegal referer""""
Posted by David Schrimpf on Aug-16-01 at 03:34 PM (EST)
Just wanted to follow up on this...

I commented out the line and it's all working for them now.

I still wonder why the problem cropped up so suddenly after months of use, and I suspect it was something to do with their network, but their IT people were not helpful.

Anyway, thanks for the support!

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents
 
8 . "Re: Illegal referer"
Posted by Bill Weiner on Aug-17-01 at 05:04 AM (EST)
Thanks for the feedback.

My guess is that their browser is not setting the HTTP_REFERER environment variable for some reason.... i.e., maybe there is some security setting on the browser now that causes the HTTP_REFERER environment variable to not get set. We'll continue to look into... and if you do find out their browser/OS that would help too.

In any case, glad it's working for you now.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.