www.uburst.com www.uburst.com

"Internal Server Error!"

Go back to the LobbyClick here to Go Back to Main ListingClick here to see helpClick here to Search the Forum

Troubleshooting Questions
Forum Type: Public
Moderator: edmunds
Time Zone: EST
Printer Friendly Format
Original Message
 
"Internal Server Error!"
Posted by MikeR. on Jun-29-01 at 04:31 PM (EST)
Greetings,

I am trying to access uReserve.pl which is installed on a Linux box running RedHat (I've tried it on 2 seperate systems, one running RedHat7.1 and the other RedHat6.1). I am using Apache-1.x for the webserver. When ever I try to access the script I receive the following error in my browser:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

In the Apache error log I find entries like the following:

[Fri Jun 29 17:09:06 2001] [error] [client 127.0.0.1] Premature end of script headers:/home/httpd/cgi-bin/ureserve.cgi


I get these same errors with both the uReserve.pl script and the testcgi.pl script. I use PERL regularly on this system and have no problem running other CGI script on it as well. The scripts are also perfectly intact....so it's not a matter of data corruption.

Any insight as to what is going wrong and how I might correct it would be greatly appreciated.


Regards,

MikeR


Click to Send Alert Message to the Administrator Click to edit this messageClick to EMail Click here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents

 Table of Contents

RE: Internal Server Error!, Bill Weiner, Jul-08-01, (1)

 

 
Click here to goto Click here to goto the Lobby
Messages in this discussion
 
1 . "RE: Internal Server Error!"
Posted by Bill Weiner on Jul-08-01 at 09:49 PM (EST)
There is definitely something wrong with the way the scripts are being installed on the server.

99% of the time, server errors with the scripts are caused by one of the three items listed in section 2 on the troubleshooting page:

http://www.uburst.com/uReserve/troubleshooting.html#ServerError

So triple-check those items.

If that still doesn't resolve the problem, then some servers require that you run a dos2unix utility on the script. See if your server has that utility, and if so, try running it on the script.

Remove this Message: Administrator and Moderator onlyClick to Send Alert Message to the Administrator Click to edit this messageClick here to reply to this messageClick here to reply to this message with quotesClick to goto the Table of Contents


Archive This Thread: Admin and Moderator OnlyRemove This Thread: Admin and Moderator Only
Click here to goto Click here to goto the Lobby

 

 

 

 

 

 

 

 

 

 

 

 
Questions or problems regarding this bulletin board should be directed to Webmaster
©1997-1999 by DCScripts. All rights reserved.