URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_applets_shopcart
Thread Number: 56
[ Go back to previous page ]

Original Message
"Order button not showing"

Posted by Jez [erk@hebes.freeserve.co.uk] on at 03:43 PM
I'm new to this so may be missing something obvious but all the input applets I've added and the shopping cart work fine but I can't get the Order button applet to work. Just the grey place-marker shows in the browser. Is there anything peculiar about this applet that makes it different from the others I've been using?

Table of contents

Messages in this discussion
"RE: Order button not showing"
Posted by Bill Weiner on at 06:14 AM
If you give me the URL, I will take a look at it. But in the meantime, make sure that you have the image that you want to be displayed as the "Button"....located in your "classes" directory.

"Applets not showing"
Posted by Jez [erk@hebes.freeserve.co.uk] on at 03:27 PM
I do have all my images in the classes file but still no joy with the order button. Also on uploading the whole site I found that none of the applets were showing. I uploaded the classes files with binary ftp and that seemed to correct the problem but then they were not working again when I viewed the site later.
Any ideas?
the URL is http://www.dd2.co.uk/CHJ_Home/chj_home.html
Choose products from the menu and then select a page from there.
We are working on the site at times over the next few days but I hope you'll be able to get through.
Thanks for your time
Jez

"RE: Applets not showing"
Posted by Bill Weiner on at 04:52 PM
I took a look at your site, and your "codebase" settings do appear to be correct.

The problem, however, may indeed have to do with transferring the files to your server.

That is, I noticed when going to your http://www.dd2.co.uk/CHJ_Home/saturnadd.html page for instance, the browser shows the following error in the status bar and on the Java Console:

# Applet exception: error: java.lang.ClassFormatError: Truncated class file

This is a pretty good indication that the class files were not successfully transferred to your server.

I would suggest deleting all class files from your classes directory at http://www.dd2.co.uk/classes/ ... and then re-transfer all of the class files to your server again. Again, be sure to transfer the class files in BINARY or RAW transfer mode (as opposed to ASCII or TEXT transfer mode).