URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_place_order
Thread Number: 168
[ Go back to previous page ]

Original Message
"Illegal Referrer"

Posted by Joe Boston [joe@globalsilks.com] on at 07:29 PM
The www for my secure url is getting lost in the order button.

In the "script_url" parameter of my uShopOrderButton applet I have it set to "https://www.domain.com/cgi-bin/ushop.cgi

Then when you hit the order button on the display_cart.html page it sends you to https://domain.com/cgi-bin/ushop.cgi

This causes two issues; 1) My secure sever is setup for https://www.domain.com not https://domain.com so the user gets an error indcating it is not a secure site. 2) The user gets an illegal referrer message because I have option 3 set to https://www.domain.com/cgi-bin/ushop.cgi

Can you tell me why the www is being lost?

Thanks
Joe


Table of contents

Messages in this discussion
"RE: Illegal Referrer"
Posted by Bill Weiner on at 09:11 PM
Upon pressing the uShopOrderButton applet, you'll be linked to whatever URL that you have specified as the applet's "script_url" parameter.... So make sure that the "script_url" parameter of your uShopOrderButton applet has the "www" in it.

The "script_url" parameter of the uShopOrderButton applet should be the full URL of where the uShop CGI script is installed on your secure server.


"Illegal Referrer"
Posted by Joe Boston [joe@globalsilks.com] on at 07:01 PM
I do have the full url in the "script_url" parameter. It actually starts with the correct url then as it displays the url changes. Would you like me to email the url?

Thanks
Joe


"RE: Illegal Referrer"
Posted by Bill Weiner on at 05:00 AM
Yes, give me the URL of the page with your uShopOrderButton applet on it and I'll check it out.