URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: udir_script_mod
Thread Number: 14
[ Go back to previous page ]

Original Message
"Couple of Modifications??"

Posted by Amanda [mail@amandas.org] on at 02:19 AM
Hi

Just purchased, downloaded and installed the deluxe edition. Just want to make 2 changes though, which are

1. how do I hide the website site address (ie; click here to visit the web site)

2. how do I make this open in a new window?

Thanks
Amanda


Table of contents

Messages in this discussion
"one more question"
Posted by amanda [mail@amandas.org] on at 02:44 AM
Also, how do I put in a horizontal rule between each listing??

"RE: one more question"
Posted by Bill Weiner on at 06:05 AM
Below are some instructions on how to implement those 3 modifications to the script:

STEP 1: Make a backup of your current udirectory.pl script... just in case.

STEP 2: Open the udirectory.pl script with any text editor such as WordPad.

STEP 3: Do a search on "get_listing_html" in order to get to the start of the subroutine that outputs the HTML for each listing.

STEP 4: Within that subroutine, locate the following lines:

elsif ($g_FIELD_TYPE[$i] eq "URL")
{
$new_listing .= "" . $gFields[$i] . "
\n";
}

And change them to:

elsif ($g_FIELD_TYPE[$i] eq "URL")
{
$new_listing .= "Click here to visit the web site
\n";
}

STEP 6: Near the very bottom of that subroutine, locate the following line:

$new_listing .= "\n\n";

Change that line to:

$new_listing .= "


\n\n";

STEP 7: Save the file (as TEXT if your editor asks)... and try it out!


"RE: one more question"
Posted by Bill Weiner on at 06:09 AM
Darn. This forum coverted some of the HTML in my previous posting. Let me try posting it again:

----------------

Below are some instructions on how to implement those 3 modifications to the script:

STEP 1: Make a backup of your current udirectory.pl script... just in case.

STEP 2: Open the udirectory.pl script with any text editor such as WordPad.

STEP 3: Do a search on "get_listing_html" in order to get to the start of the subroutine that outputs the HTML for each listing.

STEP 4: Within that subroutine, locate the following lines:

elsif ($g_FIELD_TYPE[$i] eq "URL")
{
$new_listing .= " < a href=\"" . $gFields[$i] . "\" > " . $gFields[$i] . " < /a > < br > \n";
}

And change them to:

elsif ($g_FIELD_TYPE[$i] eq "URL")
{
$new_listing .= " < a href=\"" . $gFields[$i] . "\" target=\"_num\" > Click here to visit the web site < br > \n";
}

STEP 6: Near the very bottom of that subroutine, locate the following line:

$new_listing .= " < !---------------------------------- > \n\n";

Change that line to:

$new_listing .= " < HR SIZE=1 > \n\n";

STEP 7: Save the file (as TEXT if your editor asks)... and try it out!


"RE: one more question"
Posted by Bill Weiner on at 06:12 AM
Ok, that one seemed to post correctly. But I did notice one typo, in step 4 that should be:

target=\"_new\"

instead of

target=\"_num\"


"Didn't work...."
Posted by Amanda [mail@amandas.org] on at 07:00 PM
Hi there

I followed your instructions to the letter and this is how it turns out

Name

dsaf fddsfdsfaf


Web Page: Click here to visit the web site

Any ideas??

Thanks


"Woops - the board reformatted it...."
Posted by Amanda [mail@amandas.org] on at 07:04 PM
You can take a look at the listing by going to http://65.88.177.205/listings/Test.html

thanks


"Fix for the "new" page bit...."
Posted by Amanda [mail@amandas.org] on at 07:28 PM
Fixed it. I just need to remove the extra spaces in the tags for both of the above.



"RE: Fix for the "new" page bit...."
Posted by Bill Weiner on at 05:50 AM
Yea, I had to add extra spaces around the < and > signs in order to get the code to appear in this forum.... Glad you got it working.