URL: http://www.uburst.com/cgi-bin/dcforum/dcboard.cgi
Forum: ushop_place_order
Thread Number: 129
[ Go back to previous page ]

Original Message
"illegal referrer"

Posted by Patrick [kriptap@candw.ky] on at 08:32 AM
Still having trouble with this.

The applet is set to https://secure/mysite.com
The the script is also the same, I can make everthing work fine with the refferer page off, but when I turn it one i get, illegal referrer.

I have read the forum and followed the instructions with one answer to someones problem but did not fix mine.

Thanks


Table of contents

Messages in this discussion
"RE: Illegal Referrer"
Posted by Joseph Pishgar [support@uburst.com] on at 09:32 AM
Which applet do you have set to "https://secure/mysite.com"? Could you post the code you used here?

Regards,
Joseph Pishgar


"illegal referrer error"
Posted by Jeff Lighthall [jeff@mousenaround.com] on at 08:53 AM
I am also having problem with the illegal referrer error. Like Patrick I followed all instructions in the reference pages for security. In my cgi directory on my secure server I have file permissions set to 733 (700 would not work). When referrer is set to off in the control panel everything works fine, but when set to on I get the error message. Does anyone have any ideas?

Thanks,
Jeff


"RE: illegal referrer error"
Posted by Joseph Pishgar [support@uburst.com] on at 12:22 PM
Some storefronts have multiple domains, and certain servers do not recognize crossing domains from unsecure to secure, if the domain changes. If it works with the Referrer off, by all means, leave it off. The only issue this could cause is another storefront being setup by someone else, linking to your script, and placing false orders. (Though why someone would take the time to setup a whole seperate storefront just to place false orders is beyond me.) If its an issue, please submit a support request at http://www.uburst.com/supportform.html and we'll troubleshoot it.

Regards,
Joseph Pishgar
Support Engineer
Microburst Technologies, Inc.


"RE: illegal referrer"
Posted by Bill Weiner on at 10:11 PM
Patrick and Jeff:

You must make sure that configuration question #3 at the top of your ushop.pl script (the $store_url) is set to the same domain that your HTML pages are located on.

For example, if your order applet is on the URL/page:

http://www.yourdomain.com/placeorder.html

Then configuration question #3 at the top of your ushop.pl script should be set to:

$store_url = "http://www.yourdomain.com/";